Jump to content
  • 0

Fresh install: trying to install kde-plasma gives dependencie problem


Question

I have made a fresh Funtoo install and now, I want to install kde-plasma.

Following the guide https://www.funtoo.org/KDE_Plasma_5, I add the mix-in kde-plasma-5.

Then, when running "emerge -auvDN --with-bdeps=y @world kde-plasma/plasma-meta", I get the following error:

Quote

emerge: there are no ebuilds to satisfy "x11-misc/sddm[consolekit(-)?,elogind(+)?,systemd(-)?]

(dependency required by "kde-plasma/plasma-meta-5.16.1::kde-kit" ebuild])

(dependency required by "kde-plasma/plasma-meta" [argument])

And when I try to emerge sddm alone, I see that x11-misc:sddm-0.19.0::desktop-kit will be emerge with the USE flags

Quote

USE="pam -consolekit (-elogind) -systemd -test"

So, -elogind seems to be forced somewhere while elogind is set by the profile.

Is there any way around this problem? I already tried to use the mix-in kde-plasma-5-new instead but I get the same error there.

Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0
Reverse x11-misc/sddm elogind here:
/var/git/meta-repo/kits/core-kit/profiles/funtoo/1.0/linux-gnu/flavor/workstation/package.use.mask 
by adding 
x11-misc/sddm -elogind 
to
/etc/portage/profile/package.use.mask

 

Edited by cardinal
correction
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...