Jump to content
  • 0
Sign in to follow this  
albatro74

libxmlpp 2.6 issue

Question

I'm experiencing an issue with libxmlpp. When I try to emerge @world I get the following messagei


emerge: there are no ebuilds to satisfy "dev-cpp/libxmlpp:2.6[-mgorny(-)]".
(dependency required by "media-libs/libffado-2.4.1::media-kit" [ebuild])
(dependency required by "media-sound/jack2-1.9.12-r1::media-kit[ieee1394]" [ebuild])
(dependency required by "media-video/pipewire-0.3.0::gnome-kit[jack]" [ebuild])
(dependency required by "x11-wm/mutter-3.36.2::gnome-kit" [ebuild])
(dependency required by "gnome-base/gnome-shell-3.36.2::gnome-kit" [ebuild])
(dependency required by "x11-terms/gnome-terminal-3.36.2::gnome-kit[gnome-shell]" [ebuild])
(dependency required by "gnome-base/gnome-light-3.36.0::gnome-kit" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Anyone had the same issue before?

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

An issue report at bugs.funtoo.org is needed. 

libffado-2.4.1 pulled in by jack2 with ieee1394 use flag requires libxmlpp-2.40.1 that is designated to slot 2.6 (dev-cpp/libxmlpp:2.6)

libxmlpp-3.0.1-r1 the only version available in funtoo is designated to slot 3.0 (SLOT="3.0")

A temporary workaround is to disable ieee1394 for jack2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...