Jump to content
  • 0
Sign in to follow this  
dutch-master

Issues with su

Question

Right, this is pretty annoying, Just succesfully installed a fresh Funtoo 1.4 (on some not-so-fresh hardware: Core2 Duo, 4GB RAM, 120GB SSD) and rebooted.

 

- bare metal, not a VM!

- logging in locally on the cli works (as root)

- remote login (ssh) as normal user works

- elevating permissions to root (su) fails

- I've had this on a different system (Devuan Beowulf) and the recommendation was to revert to the old Unix way: su -

- using su - fails with "permission denied" error, repeatedly

- alternative was to add

ALWAYS_SET_PATH yes

into /etc/default/su. I did so, no change in behaviour. Reboot, tried again, again, no change in behaviour, I still can't elevate permissions to root remotely.

 

Unless this can be solved, I'd have to revert this system to Devuan Ascii, 'cause I know it worked on that.

 

Suggestions? TIA!

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

The output is only the group name of the regular user. I had performed the usermod command as per the wiki install page, but it bombed out with an error about plugdev group not existing. I'll redo the usermod command w/o the plugdev group tomorrow. In 4 hrs the alarm goes to get to work... 😴

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...