Jump to content
Read the Funtoo Newsletter: Summer 2023 ×

Problem ego sync

Recommended Posts

I found a problem in the new version of the system with the gnome, I already tested the previous version and it worked, this new version presents a problem in the chroot time to install and configure the system. I used intel64-ivybridge gnome 2020-02-02

(chroot) darkstar / # ego sync
Running as root user (will drop perms for sync.)
WARNING: Can't write to meta-repo -- running as read-only.
Syncing meta-repo
WARNING: Cannot update repos.conf as meta-repo does not exist.
Updating profiles at /etc/portage/make.profile/parent...
ERROR: Ego encountered an unexpected error: KeyError
ERROR: Full traceback written to /tmp/ego-traceback-2721.txt.

(chroot) darkstar / # nano /tmp/ego-traceback

'release_defs'Traceback (most recent call last):
  File "/usr/bin/ego", line 118, in <module>
    EgoModule.run_ego_module(action, econfig, args, VERSION)
  File "/usr/share/ego/python/ego/module.py", line 103, in run_ego_module
  File "/usr/share/ego/python/ego/module.py", line 88, in __call__
  File "/usr/share/ego/modules/sync.ego", line 434, in handle
  File "/usr/share/ego/modules/sync.ego", line 393, in sync_meta_repo_and_kits
    EgoModule.run_ego_module('profile', self.config, ['update'])
  File "/usr/share/ego/python/ego/module.py", line 103, in run_ego_module
  File "/usr/share/ego/modules/profile.ego", line 313, in __call__
  File "/usr/share/ego/python/ego/module.py", line 88, in __call__
  File "/usr/share/ego/modules/profile.ego", line 294, in handle
  File "/usr/share/ego/modules/profile.ego", line 130, in handle_write
    self.tree.write(self.config, outfile)
  File "/usr/share/ego/python/ego/profile.py", line 462, in write
    for kit in self.config.all_kit_names_in_release:
  File "/usr/share/ego/python/ego/config.py", line 92, in all_kit_names_in_release
    return self.kit_info_metadata["release_defs"][self.release].keys()
KeyError: 'release_defs'

Remembering that I did not make any changes to the system and anyway, even formatting and extracting tar.xz I get the same error.

Thank you and I hope for the answer.

Sorry, when i made the post it doubled because i was not logged in, i'm new to the site i don't know how to delete the other post.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...