Jump to content
  • 0
Sandro

Error making boot-update

Question

hi to All :)

I've encountered this trouble:

ci74771ht ~ # boot-update 
 
boot-update 1.7.2 /
Copyright 2009-2015 Funtoo Technologies
 
 [use option "-l" for license info, "-h" for help]
 
 * Generating config for grub...
 
 * ERROR : /usr/sbin/grub-probe  --device None --target=abstraction
 
 * Did not complete successfully.
 
ci74771ht ~ # 

my /boot.conf:

ci74771ht ~ # cat /etc/boot.conf
boot {
        generate grub
        default "Windows 8.1 x64" 
        timeout 3 
}
 
"Windows 8.1 x64" {
        type win8
        params root = /dev/sda1
}
 
"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params += real_root=/dev/sda6 rootfstype=ext4

I had to manually manipulate /boot/grb/grub.cfg cause boot-update gave to me rootfsrype=xfs instead of exr4 8since declared in boot.conf).

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hi Sandro.

I believe that's because each param must have it's own line.  Like this:

...
"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params += real_root=/dev/sda6
        params += rootfstype=ext4

Share this post


Link to post
Share on other sites
  • 0

Hi dear; i experiented, but the result is the same

ci74771ht ~ # cat /etc/boot.conf
boot {
        generate grub
        default "Windows 8.1 x64"
        timeout 3
}

"Windows 8.1 x64" {
        type win8
        params root = /dev/sda1
}

"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params += real_root=/dev/sda6
        params += rootfstype=ext4
}
ci74771ht ~ # boot-update

boot-update 1.7.2 /
Copyright 2009-2015 Funtoo Technologies

 [use option "-l" for license info, "-h" for help]

 * ERROR : Parse Error: Duplicate variable "params" on line 16
 * Did not complete successfully.

Sorry :(

Share this post


Link to post
Share on other sites
  • 0

Ah, I see.  It's because the first entry should not have the +=.  I apologize for leading you astray.  Like this:

"Funtoo Linux genkernel" {
        kernel kernel[-v]
        initrd initramfs[-v]
        params real_root=/dev/sda6
        params += rootfstype=ext4

Here's mine, working fine:

"And we're gonna have Funtoo!" {
	kernel vmlinuz[-v]
	initrd /initramfs-funtoo[-v]
	params quiet
	params += splash
	params += nomodeset
	params += raid=noautodetect
	params += pcie_aspm=force
	params += video=uvesafb:1440x900-32,mtrr:3,ywrap
	params += rootfstype=auto
	params += rd.luks=0
	params += rd.lvm=0
	params += rd.md=0
	params += rd.dm=0
	params += rootflags=rw,noatime,attr2,inode64,noquota
	params += resume=UUID=a6d5ff0d-a43c-4586-9552-651be34fa82c
	params += root=auto
}

Share this post


Link to post
Share on other sites
  • 0

I'm Sorry; but also removing "+=" for first entry instruction there aren't changes about errors.

However .... Thanxs 1000000000 for your great aid :) :) :)

God Bless You ForEver !!! :) :) :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...