Jump to content
  • 0
russtopia

menulibre cannot install after 1.4-release ego sync

Question

drek /etc/portage/make.profile # ego sync
Syncing meta-repo
M    kits/core-hw-kit
M    kits/core-kit
M    kits/desktop-kit
M    kits/dev-kit
M    kits/editors-kit
M    kits/games-kit
M    kits/gnome-kit
M    kits/haskell-kit
M    kits/java-kit
M    kits/kde-kit
M    kits/lang-kit
M    kits/lisp-scheme-kit
M    kits/llvm-kit
M    kits/media-kit
M    kits/ml-lang-kit
M    kits/net-kit
M    kits/nokit
M    kits/perl-kit
M    kits/python-kit
M    kits/ruby-kit
M    kits/science-kit
M    kits/security-kit
M    kits/text-kit
M    kits/xfce-kit
M    kits/xorg-kit
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 767575b kit updates
Already up to date.
Syncing core-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 53f66a8b updates
Already up to date.
Syncing core-hw-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 5b78fa3 updates
Already up to date.
Syncing core-ui-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 4dc037b updates
Already up to date.
Syncing core-server-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 0edc2c7 updates
Already up to date.
Syncing core-gl-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 2d999e0 updates
Already up to date.
Syncing security-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 20ee31b updates
Already up to date.
Syncing xorg-kit branch 1.20-release
Already on '1.20-release'
Your branch is up to date with 'origin/1.20-release'.
HEAD is now at 6034bc4 Merge pull request #8 in INDY/xorg-kit from ~SHADOWNGOZ/xorg-kit:1.20-release to 1.20-release
Already up to date.
Syncing gnome-kit branch 3.34-prime
Already on '3.34-prime'
Your branch is up to date with 'origin/3.34-prime'.
HEAD is now at c70bb8e5 FL-6905: add ability via meson to manually disable pulseaudio.
Already up to date.
Syncing rust-kit branch 1.37-prime
Already on '1.37-prime'
Your branch is up to date with 'origin/1.37-prime'.
HEAD is now at 8d40584 Merge pull request #4 in INDY/rust-kit from ~BCOWAN/rust-kit:1.37-prime to 1.37-prime
Already up to date.
Syncing xfce-kit branch 4.13-release
Already on '4.13-release'
Your branch is up to date with 'origin/4.13-release'.
HEAD is now at b6e2fb2 updates
Already up to date.
Syncing kde-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 141e999 updates
Already up to date.
Syncing desktop-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 568a8e2 updates
Already up to date.
Syncing media-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 8de68e86e updates
Already up to date.
Syncing editors-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 765686a5 updates
Already up to date.
Syncing net-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 2e50a7945 updates
Already up to date.
Syncing text-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 71ded07 updates
Already up to date.
Syncing science-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at f7632adf updates
Already up to date.
Syncing games-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 3ae1186 updates
Already up to date.
Syncing perl-kit branch 5.28-release
Already on '5.28-release'
Your branch is up to date with 'origin/5.28-release'.
HEAD is now at d3e1929 Cleaning up perl ebuilds.
Already up to date.
Syncing java-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at f9224ce updates
Already up to date.
Syncing ruby-kit branch 2.6-prime
Already on '2.6-prime'
Your branch is up to date with 'origin/2.6-prime'.
HEAD is now at f05a922 Latest updates.
Already up to date.
Syncing haskell-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 7c08897 updates
Already up to date.
Syncing ml-lang-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 556e69e updates
Already up to date.
Syncing lisp-scheme-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 9e31a85 updates
Already up to date.
Syncing python-kit branch 3.7-release
Already on '3.7-release'
Your branch is up to date with 'origin/3.7-release'.
HEAD is now at a49903c Moving dnspython to python-modules-kit.
Already up to date.
Syncing lang-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 3194c44 updates
Already up to date.
Syncing llvm-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at aac72a1 updates
Already up to date.
Syncing dev-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at f443aed7 updates
Already up to date.
Syncing python-modules-kit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 02553f82 updates
Already up to date.
Syncing nokit branch 1.4-release
Already on '1.4-release'
Your branch is up to date with 'origin/1.4-release'.
HEAD is now at 4c791b1a updates
Already up to date.
Sync successful and kits in alignment! :)
Updating /etc/portage/repos.conf...
Updating profiles at /etc/portage/make.profile/parent...
drek /etc/portage/make.profile # python --version
Python 3.7.3
drek /etc/portage/make.profile # emerge menulibre
Calculating dependencies |

!!! Problem resolving dependencies for x11-misc/menulibre
... done!

!!! The ebuild selected to satisfy "menulibre" has unmet requirements.
- x11-misc/menulibre-2.2.1::desktop-kit USE="" PYTHON_TARGETS="-python3_5 -python3_6"

  The following REQUIRED_USE flag constraints are unsatisfied:
    any-of ( python_targets_python3_5 python_targets_python3_6 )

drek /etc/portage/make.profile # 

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Most likely a very simple fix of adding python 3.7 to to python_compat in the ebuild

if you could file a bug on bugs.funtoo.org or fix and make a pull request to code.funtoo.org it would be appreciated. Thanks 🙂

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...