Jump to content

russtopia

Members
  • Content Count

    9
  • Joined

  • Last visited

  1. While emerging nextcloud-client, which has qtwebengine has a dependency, emerge of the latter fails (see full errors described in external QT bug link below). In file included from ../../3rdparty/chromium/third_party/skia/third_party/skcms/skcms.cc:1911: ../../3rdparty/chromium/third_party/skia/third_party/skcms/src/Transform_inl.h:537:6: note: ‘template<int I, int B> void clut(const skcms_A2B*, I32x8, I32x8, Fx8*, Fx8*, Fx8*, Fx8)’ previously declared here 537 | void clut(const skcms_A2B* a2b, I32 ix, I32 stride, F* r, F* g, F* b, F a) { This likely isn't a Funtoo bug per se; t
  2. Update: Seems I was finally able to get the emerge to succeed by unmerging docbook-sgml-dtd (all versions -- had multiple earlier versions somehow?), then finally explicitly bringing in only the newest as of Jan 2020, 4.5: # emerge app-text/docbook-sgml-dtd:4.5 Seemed I also had to manually emerge fuse as the ebuild didn't bring it in as a dependency.
  3. $ sudo emerge libreoffice Calculating dependencies... done! >>> Verifying ebuild manifests >>> Running pre-merge checks for x11-drivers/xf86-input-wacom-0.36.0-r2 * Determining the location of the kernel source code * Found kernel source directory: * /usr/src/linux * Could not find a Makefile in the kernel source directory. * Please ensure that /usr/src/linux points to a complete set of Linux sources * Unable to calculate Linux Kernel version for build, attempting to use running version >>> Running pre-merge checks for media-libs/libg
  4. drek /etc/portage/make.profile # ego sync Syncing meta-repo M kits/core-hw-kit M kits/core-kit M kits/desktop-kit M kits/dev-kit M kits/editors-kit M kits/games-kit M kits/gnome-kit M kits/haskell-kit M kits/java-kit M kits/kde-kit M kits/lang-kit M kits/lisp-scheme-kit M kits/llvm-kit M kits/media-kit M kits/ml-lang-kit M kits/net-kit M kits/nokit M kits/perl-kit M kits/python-kit M kits/ruby-kit M kits/science-kit M kits/security-kit M kits/text-kit M kits/xfce-kit M kits/xorg-kit Already on '1.4-release' Your branch
  5. Thank you, I will try that! [EDIT] This got me past gvfs. Thank you x1000 :)
  6. Hi, whilst trying to upgrade @world on my Funtoo system with "-systemd", I now hit a failure to emerge new gvfs. There appear to be multiple errors in the current ebuild (gvfs-1.38.1) which render it inoperable for a systemd-free build: Digging into the ebuild dir /var/tmp/portage/gnome-base/gvfs-1.38.1/work/gvfs-1.38.1, it seems the logic to require systemd is tangled with a meson 'tmpfilesdir' option as well. Additionally, default meson_options.txt has option('goa', type: 'boolean', value: true, ...) which turns on a dependency for 'goa-1.0' which appears to not exis
  7. Aha, thank you! I will see if I can upgrade. I am not sure how to check my version but I'll research as you suggest. My ego.conf is: $ cat /etc/ego.conf # This is the ego.conf file [kits] # You can set your default kits here. Unset kits will use the Funtoo default prime/master # branch by default. # python-kit = 3.6-prime
  8. In a half-woken state this morning, I posted this to the Gentoo forums, where I was told that this is '...an ancient version of exiv2, riddled with security holes' so it sounds like this package needs updating from Gentoo upstream. $ sudo emerge exiv2 Calculating dependencies... done! >>> Verifying ebuild manifests >>> Emerging (1 of 1) media-gfx/exiv2-0.26::media-kit >>> Downloading 'http://distfiles.gentoo.org/distfiles/exiv2-0.26-trunk.tar.gz' --2018-05-10 09:51:54-- http://distfiles.gentoo.org/distfiles/exiv2-0.26-trunk.tar.gz Resolving distf
×
×
  • Create New...