Jump to content
  • 0
Sign in to follow this  
Forest Fire

To Grub Or Not And It's A Lonely World (Apparently)

Question

Hi, new user here.

 

I am installing Funtoo on an otherwise empty 1 TB drive, sdb. The other drive,  sda, boots PC-BSD via grub. Both drives have GPT partition tables and the system boots with UEFI. Sda is a 250 GB SSD and is full. The Funtoo installation will take up about 200 GB on sdb, a conventional drive.

 

Despite a whole lot of Googling, I cannot determine the best practice in this instance. Do I install grub in the second (sdb) drive as part of the Funtoo install, or do I skip that step when I get to it and simply update grub on sda only.  

 

Second question. I got this after doing emerge --depclean following the first emerge operation in the installation process.



!!! You have no world file.

I went no further. Do I have a problem here?

 

Thank you.

 

 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Well, updating grub on sda did not work. It could not find Funtoo.  I didn't have the patience to dig into PCBSD's grub configuration, so I proceeded to install grub on Funtoo's drive, which resulted in changing the bios settings on my desktop. :angry:  The machine now boots into Funtoo, but there is no entry for PCBSD. Apparently, there is a lot I don't know about UEFI bioses and booting. 

 

I found the setting in the bios that controls which drive is used for booting. The Funtoo installation had changed it. I changed it back to sda and PCBSD booted OK, but still no joy on booting Funtoo from the sda grub menu.

 

During my searching, I discovered that UEFI bioses usually allow boot drive selection via the F11 or F12 function key. Mine does not. That may be due to the fact that is an industrial system versus a desktop oriented box. To change the boot drive, I have to go into the bios and change a setting. 

 

So, I have two options. I can see about having Funtoo control the grub boot menu for all OSes, or beat my head against the wall trying to figure out why PCBSD's boot menu isn't working properly. I will probably do the former. Fortunately, that PCBSD installation isn't all that critical at the moment.

 

I will leave this unsolved for now.

 

 

Share this post


Link to post
Share on other sites
  • 0

I don't have a lot of experience dual booting with Funtoo nonetheless I'm going to suggest that you add an entry for PC-BSD in your /etc/boot.conf and run boot-update. That should create an entry for PC-BSD in your Funtoo managed Grub menu. The specifics of what to add to boot.conf, to get PC-BSD booting, I am unsure of. Perhaps someone else can chime in?

Share this post


Link to post
Share on other sites
  • 0

Grub is capable of auto detecting OSes, so it may not be an issue from the Funtoo side. I need to get the rest of Funtoo installed before I go any further, though.

not quite. look at

$man boot.conf

 

here is mine for an example

 

 $ cat /etc/boot.conf
boot {
generate grub
default "Funtoo Linux" 
timeout 3 
}
 
"Funtoo Linux" {
kernel kernel-xfce
initrd initramfs-xfce
params real_root=/dev/sda2
params += video=800x600
}
 
"Funtoo Linux g3" {
kernel kernel-deb
initrd initramfs-deb
params real_root=/dev/sda3
        params += video=800x600 
 
"Funtoo Linux better-initramfs" {
kernel vmlinuz[-v]
initrd /initramfs.cpio.gz
}
"Windows 7" {
type win7
params root=/dev/sdc1
}
 
"kde" {
       kernel kernel-kde
       initrd initramfs-kde
       params real_root=/dev/sdd1        
       params += rootfstype=ext4
       params += video=800x600
}

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...