Jump to content
  • 0
pennine

Having trouble with LVM on LUKS

Question

subj. Can't boot into the system.

IMG-20191224-010902.jpg

I'm 100% sure i'm typing the password correctly. Grub's installed with "device-mapper" flag, encrypted-root mix-ins is enabled, I've also upgraded @world with it.

I've also tried a genkernel's kernel and initramfs with --luks --lvm, same result.

There are some additional parameters in grub (not from boot.conf), I've tried to remove them, same result.

IMG-20191224-010455.jpg

ls /boot:

EFI
System.map-debian-sources-lts-x86_64-4.19.67_p2-r3
System.map-genkernel-x86_64-4.19.67_p2-r3-debian-sources-lts
early_ucode.cpio
grub
initramfs-debian-sources-lts-x86_64-4.19.67_p2-r3
initramfs-genkernel-x86_64-4.19.67_p2-r3-debian-sources-lts
kernel-debian-sources-lts-x86_64-4.19.67_p2-r3
kernel-genkernel-x86_64-4.19.67_p2-r3-debian-sources-lts

epro show:

=== Enabled Profiles: ===

        arch: x86-64bit
       build: current
     subarch: intel64-broadwell
      flavor: desktop
     mix-ins: gnome
     mix-ins: gfxcard-nvidia
     mix-ins: gfxcard-amdgpu
     mix-ins: gfxcard-radeon
     mix-ins: gfxcard-intel
     mix-ins: encrypted-root


=== Python kit: ===

      branch: 3.7-release

=== All inherited flavor from desktop flavor: ===

                     workstation (from desktop flavor)
                            core (from workstation flavor)
                         minimal (from core flavor)

=== All inherited mix-ins from desktop flavor: ===

                               X (from workstation flavor)
                           audio (from workstation flavor)
                             dvd (from workstation flavor)
                           media (from workstation flavor)
      mediadevice-audio-consumer (from media mix-in)
                mediadevice-base (from mediadevice-audio-consumer mix-in)
      mediadevice-video-consumer (from media mix-in)
                mediadevice-base (from mediadevice-video-consumer mix-in)
        mediaformat-audio-common (from media mix-in)
          mediaformat-gfx-common (from media mix-in)
        mediaformat-video-common (from media mix-in)
                  console-extras (from workstation flavor)
                           print (from desktop flavor)

=== All inherited flavor from gnome mix-ins: ===

                         desktop (from gnome-kit:gnome mix-in)
                     workstation (from desktop flavor)
                            core (from workstation flavor)
                         minimal (from core flavor)

=== All inherited mix-ins from gnome mix-ins: ===

                 gnome-kit:gnome (from gnome mix-in)
                               X (from workstation flavor)
                           audio (from workstation flavor)
                             dvd (from workstation flavor)
                           media (from workstation flavor)
      mediadevice-audio-consumer (from media mix-in)
                mediadevice-base (from mediadevice-audio-consumer mix-in)
      mediadevice-video-consumer (from media mix-in)
                mediadevice-base (from mediadevice-video-consumer mix-in)
        mediaformat-audio-common (from media mix-in)
          mediaformat-gfx-common (from media mix-in)
        mediaformat-video-common (from media mix-in)
                  console-extras (from workstation flavor)
                           print (from desktop flavor)

lsblk:

NAME                   SIZE UUID                                   FSTYPE      MOUNTPOINT
loop0                788.8M                                        squashfs    
sda                  465.8G                                                    
sdb                  111.8G                                                    
├─sdb1                 1.5G 0573-0081                              vfat        /boot
└─sdb2               110.3G 25268b45-b7c4-4ae5-bbbd-663a843faa5f   crypto_LUKS 
  └─dmcrypt_root     110.3G pVVWGh-fMRv-pWUS-M8AA-gKfu-0GYw-aAEpaS LVM2_member 
    ├─vol_group-swap     8G 78238a3f-6cd6-4cf5-b1a4-14fb7ad3856f   swap        [SWAP]
    ├─vol_group-root    35G 33179502-4a4e-456d-8ca8-eb0b73320235   ext4        /
    └─vol_group-home  67.3G ac786bec-277b-4bd3-bf84-d548eb7620ce   ext4        /home
sdc                   14.7G 2019-04-14-11-35-22-00                 iso9660     
├─sdc1                 841M 2019-04-14-11-35-22-00                 iso9660     
└─sdc2                 1.4M 0A1C-A545                              vfat 

fstab:

UUID=0573-0081                               /boot         vfat      noauto,noatime                  1 2
/dev/mapper/vol_group-swap                   none          swap      sw                              0 0
/dev/mapper/vol_group-root                   /             ext4      noatime,nodiratime,defaults     0 1
/dev/mapper/vol_group-home                   /home         ext4      noatime,nodiratime              0 0

boot.conf:

boot {
	generate grub
	default "Funtoo Linux" 
	timeout 3 
}

"Funtoo Linux" {
	kernel bzImage[-v]
}

"Funtoo Linux genkernel" {
	kernel kernel[-v]
	initrd initramfs[-v]

	# IMPORTANT: Most users will want to remove "nomodeset", below!
	#
	# It is included in the initial install to ensure that virtually all
	# systems boot up with a readable initial console.

	# But all graphics drivers (with the one exception of the proprietary
	# NVIDIA drivers) REQUIRE mode setting to be enabled, and thus the
	# nomodeset option must be REMOVED prior to setting up a graphical
	# environment or X will not start. Remember to run "ego boot update" after
	# removing the option, and then reboot prior to configuring X.

	# Also note that if you are using a 4K or higher resolution display, your
	# console text may become very small after enabling kernel mode setting
	# since it will display your console at the native resolution of your
	# display.

	params += crypt_root=UUID=25268b45-b7c4-4ae5-bbbd-663a843faa5f dolvm real_root=/dev/mapper/vol_group-root rootfstype=ext4 resume=swap:/dev/mapper/vol_group-swap quiet
}

 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Hey there, Pennine,

 

     Did you ever get an answer to this? I'm curious, as I was having a devil of a time with LVM at install and had to go to a vanilla partition strategy to get it installed.

Share this post


Link to post
Share on other sites
  • 0

try booting again using a livecd, then chroot (following the steps here - pay close attention to the mount procedure, its options, etc)

then:

# emerge grub cryptsetup lvm2
# emerge intel-microcode iucode_tool linux-firmware
# emerge debian-sources-lts
# emerge @module-rebuild

 

Share this post


Link to post
Share on other sites
  • 0
On 3/26/2020 at 1:53 AM, kratsy-tony said:

try booting again using a livecd, then chroot (following the steps here - pay close attention to the mount procedure, its options, etc)

then:


# emerge grub cryptsetup lvm2
# emerge intel-microcode iucode_tool linux-firmware
# emerge debian-sources-lts
# emerge @module-rebuild

 

Hi there.

I am, more or less, at the same point, after reading this thread from the beginning.  At least, I get to type-in my passphrase and then I get the same error(s) as in the photo posted in the 1st message.  I have followed the installation instructions at both https://www.funtoo.org/Install and https://www.funtoo.org/Rootfs_over_encrypted_lvm, trying to put in the `crypto` stuff at the right moment.  The difference being, I use `debian-sources` and not `debian-sources-lts`.

I have also installed all of `grub`, `cryptsetup`, `lvm2` and inter microcode stuff (as in the quote section here) before rebooting.

Do you really need to re-compile the kernel after installation ofr `intel-microcode iucode_tool linux_firmware`? As per the installation tutorial, these come after the compilation of the kernel. And it seems they concern the bootloader, if I understand correctly.

Any suggestion on how to proceed?

Share this post


Link to post
Share on other sites
  • 0

One important note in https://www.funtoo.org/Rootfs_over_encrypted_lvm reads:

Quote

As of August 2016, better-initramfs is not required with debian-sources as included in current Funtoo stages. Unless you are doing something not with debian-sources as comes with the Funtoo stage, you can safely skip to the section on editing /etc/boot.conf.

I have installed  the newer debian-sources kernel. It is not clear to me if I do need or if I do not need to go on with (re-?)building the initramfs with either better-initramfs or genkernel.

Thanks for any tips.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...