Jump to content
funtoo forums
  • 0
Sign in to follow this  
upc0d3

Awesome window manager

Question

Hello guys,

 

I start to use the Awesome Window Manager which is great to me. Highly functional, really light. And I'm enjoying it a lot.

But I'm having some problems, that I'm not finding answers.

 

1. I'm using it in my laptop. I can't get the functions key work. Like the mouse I can't lock and unlock. The brightness doesn't work as well.

Does anybody knows how to solve it?

 

2. For my file manager I'm using the Thunar (which came from XFCE4). And I can't move the windows it's just fullscreen or halfscreen.

 

3. Every time I'm going to delete a file the thunar just close. I've to open it again and then delete the file. Is that normal? What Am I missing here?

 

For now is just that!

 

Thanks you all!

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

1. I'm using it in my laptop. I can't get the functions key work. Like the mouse I can't lock and unlock. The brightness doesn't work as well.

Does anybody knows how to solve it?

 

2. For my file manager I'm using the Thunar (which came from XFCE4). And I can't move the windows it's just fullscreen or halfscreen.

 

3. Every time I'm going to delete a file the thunar just close. I've to open it again and then delete the file. Is that normal? What Am I missing here?

 

They certainly sound like strange problems. For 2. is it set to floating when you open it (look at the icons before the name in the statusbar) and which tile mode is the workspace set to?

 

I don't use thunar but it sounds like you might be missing a USE flag or dependency for it perhaps?

Share this post


Link to post
Share on other sites
  • 0

The function keys can be a very hairy thing.  It starts at the kernel, the x86 platform specific device drivers.  Even if you have that right you can still have issues and may have to use something like acpi to make it all work.  I'm sorry, it's been a few years since I messed with all that so I don't remember details, but they're out there.  I also don't remember much about Awesome but I doubt it's the problem.  Often window managers have a hotkey assignment settings screen, that may help.  You can see if the kernel has the proper drivers with grep hotkey <system log name>.  Here's what I get:

Feb 20 11:40:57 [kernel] [   27.268316] input: HP WMI hotkeys as /devices/virtual/input/input11

.

 

Never used Thunar, I wonder if it could be a dependency problem, since it's what, from xfce?  You might try spacefm, it's a much lighter weight, very functional file manager.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...