Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

Troubles updating gnome




I've trouble updating @world expecially the last gnome.

[ebuild     U  ] gnome-base/gnome-extra-apps-3.34.0 [3.32.0]
[ebuild     U  ] gnome-base/gnome-control-center-3.34.1 [3.32.2] USE="libinput*"  
[ebuild     U  ] gnome-base/gnome-core-apps-3.34.0 [3.32.0]
[ebuild     U  ] gnome-base/gnome-3.34.0 [3.32.0]
[blocks B      ] dev-python/pygtk ("dev-python/pygtk" is blocking x11-libs/pango-1.44.7)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:


 (x11-libs/pango-1.44.7:0/0::gnome-kit, installed) pulled in by
   >=x11-libs/pango-1.44.7 required by (dev-cpp/pangomm-2.42.0-r1:1.4/1.4::gnome-kit, installed)
   ^^               ^^^^^^                                                                        
   (and 14 more with the same problem)

 (x11-libs/pango-1.42.4-r2:0/0::gnome-kit, ebuild scheduled for merge) pulled in by
   <x11-libs/pango-1.44 required by (dev-python/pygtk-2.24.0-r6:2/2::gnome-kit, ebuild scheduled f
or merge)
   ^               ^^^^                                                                           

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

 (dev-python/pygtk-2.24.0-r6:2/2::gnome-kit, ebuild scheduled for merge) pulled in by
   dev-python/pygtk:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] (dev-python
/pygtk:2[python_targets_python2_7(-),-python_single_target_python2_7(-)]) required by (app-portage/
porthole-0.6.1-r5:0/0::nokit, installed)                                                            
   >=dev-python/pygtk-2.8:2[python_targets_python2_7(-)?,-python_single_target_python2_7(-)] (>=de
v-python/pygtk-2.8:2[python_targets_python2_7(-),-python_single_target_python2_7(-)]) required by (
dev-python/pygtksourceview-2.10.1-r1:2/2::python-modules-kit, installed)                            
ngle_target_python3_6(-),-python_single_target_python3_7(-),python_single_target_python2_7(+)]) req
uired by (media-gfx/gimp-2.10.10-r1:2/2::media-kit, installed)

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):


what can i do to solve ?

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 1

Right now, the general Funtoo advice is to remove pygtk (and anything that depends on it) because pygtk has been unmaintained for years.

It looks like the main culprit is app-portage/porthole.  gimp and nmap should upgrade without any pygtk dependency (double-check package.user and other USE flag overrides).  So, you will need to remove app-portage/porthole to remove pygtk and upgrade to GNOME 3.34.

I'm sorry to say that right now, the pygtk dilemma is still unresolved.  It hit LXDE quite hard.  The latest information is in this bug report: https://bugs.funtoo.org/browse/FL-6860

Link to comment
Share on other sites

  • 0

The problem is that something is depending on pygtk, which currently doesn't build under the newer pango.  This might be fixed in the future.  Research is ongoing.

Gimp should have dropped the requirement on pygtk (since we have disabled the python USE flag of Gimp by default in Funtoo).

What else is pulling in pygtk?  Try

equery depends pygtk

Also, try rerunning the command with --verbose-conflicts.

Link to comment
Share on other sites

  • 0

Ok ... thank You.

sandro@ci74771ht:~$ equery depends pygtk
* These packages depend on pygtk:
app-portage/porthole-0.6.1-r5 (dev-python/pygtk:2[python_targets_python2_7(-)?,-python_single_targe
dev-python/pygtksourceview-2.10.1-r1 (>=dev-python/pygtk-2.8:2[python_targets_python2_7(-)?,-python
media-gfx/gimp-2.10.10-r1 (>=dev-python/pygtk-2.10.4:2[python_targets_python2_7(-)?,-python_single_
net-analyzer/nmap-7.70 (zenmap ? dev-python/pygtk:2[python_targets_python2_7(-)?,-python_single_tar

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...