Jump to content
funtoo forums
  • 0
digifuzzy

package wants automake-1.1x

Question

FL-1894 brought in update of automake to 1.14. This was done just a few days ago.

 

I went to rebuild media-gfx/graphviz to debug an issue in my personal code. I needed to rebuild the graphviz so that I could trace memory leaks with valgrind.

 

Problem was that graphviz (built before) gave no problems but suddenly just stopped on the compile phase complaining that it needed automake-1.13. Since slotting wasn't an issue, I was able to re-emerge automake-1.13. The rebuild of graphviz worked fine.

 

Is this really a bug with ebuilds or upstream where build fails because of a dependency on a specific automake?

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Bizarre. I just emerge'd graphviz on my second machine (but not synched first). And I didn't get a fail?

On my desktop (where I encountered the error) I was re-emerging with FEATURES=splitdebug, then the error occurred.

 

I'll take another look. If I run into something, I'll post a bug.

Thanks, Oleg. Appreciate the feedback.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...