Jump to content
  • 0

Non-responsive mouse


gevious
 Share

Question

Hi all,

 

I've been running funtoo on my ASUS N56V for over 2 years now. One thing I bump into time and again is my mouse (Logitec M325) which doesn't always respond well. I have essentially 3 use cases (2 broken one working)

 

1. After boot, the mouse is generally not too reliable and lags quite a bit every now and then

2. If after boot, I pull the wireless dongle out and reinsert it, the mouse is stable until the next boot.

3. Whenever I run purely on battery, the mouse is often non-responsive or lags quite a bit. Incidentally, the touch pad works just fine.

 

I'd love to resolve some of these issues, but I'm not sure where to start. I used to run laptop-mode but turned it off, since on battery it was spinning my drive down a lot. So as far as I know I'm not running any fancy software that turns things off when I'm only on the battery.

 

For what its worth, i'm running the Awesome WM.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

I wonder if perhaps you are having issues with usb power management?  This doc tells in detail (!) how to change it, worth a try.  I have had similar in the past due to pm.  All "Energy Star" (or whatever green buzzword they are using today) devices are supposed to work with it, that's the concept, the reality is some don't.

In a nutshell, you've got to find out where your device is in /sys/bus/usb/devices, one way would be to lsusb to get the bus and device number, go into /sys/bus/usb/devices/<bus><device>/power directory and try changing autosuspend from 1 to 0 (such as "echo 0 > autosuspend").

Incidentally, you can control that drive spindown in laptop-mode-tools, probably the usb autosuspend too, I forget.  Gotta get your hands dirty in the config files though.

Link to comment
Share on other sites

  • 0

I recall having this issue too. My problem was like what sputnik said. I had to look for about 10 minutes to find where I configured the fix. I don't know about editing the config files in /sys/bus/... I will assume you have not figured it out since you did not add [solved] to the title (using full editor on original comment).

 

Assuming you did not screw anything up by 'fixing' things, and assuming  you have the same issue I did, you, gevious, will have this corrected in 5 minutes. It will take me longer to discover what I did and explain the steps. lol

 

Step 1: Verify you are using laptop-mode-tools package.

me@XXX ~ $ emerge -s laptop-mode
Searching...
[ Results for search key : laptop-mode ]
[ Applications found : 1 ]

*  app-laptop/laptop-mode-tools
      Latest version available: 1.66
      Latest version installed: 1.66
      Size of files: 108 kB
      Homepage:      http://www.samwel.tk/laptop_mode/
      Description:   Linux kernel laptop_mode user-space utilities
      License:       GPL-2
me@XXX ~ $

If app-laptop/laptop-mode-tools is NOT installed, these steps will NOT fix your problem, so abort.

If app-laptop/laptop-mode-tools IS installed, these steps will (probably) fix your problem, so please continue.

 

Step 2: Find the configurate option(s) where your mouse is being managed to save power.

 

Run less to look at your config file:

me@XXX ~ $ less /etc/laptop-mode/conf.d/usb-autosuspend.conf

This is the top of mine.

#
# Configuration file for Laptop Mode Tools module usb-autosuspend.
#
# For more information, consult the laptop-mode.conf(8) manual page.
#


###############################################################################
# USB autosuspend settings
# ------------------------
#
#__COMMENT If you enable this setting, laptop mode tools will automatically enable the
#__COMMENT USB autosuspend feature for all devices.
#__COMMENT
#__COMMENT NOTE: Some USB devices claim they support autosuspend, but implement it in a
#__COMMENT broken way. This can mean keyboards losing keypresses, or optical mice turning
#__COMMENT their LED completely off. If you have a device that misbehaves, add its USB ID
#__COMMENT to the blacklist below and complain to your hardware vendor.
#
################################################################################

# Enable debug mode for this module
# Set to 1 if you want to debug this module
DEBUG=0

# Enable USB autosuspend feature?
# Set to 0 to disable
CONTROL_USB_AUTOSUSPEND="0"

# Set this to use opt-in/whitelist instead of opt-out/blacklist for deciding
# which USB devices should be autosuspended.
# AUTOSUSPEND_USE_WHITELIST=0 means AUTOSUSPEND_*_BLACKLIST will be used.
# AUTOSUSPEND_USE_WHITELIST=1 means AUTOSUSPEND_*_WHITELIST will be used.
AUTOSUSPEND_USE_WHITELIST=0

# The list of USB IDs that should not use autosuspend. Use lsusb to find out the
# IDs of your USB devices.
# Example: AUTOSUSPEND_USBID_BLACKLIST="046d:c025 0123:abcd"
##AUTOSUSPEND_USBID_BLACKLIST=""
AUTOSUSPEND_USBID_BLACKLIST="046d:c52f"

Note the two key lines that I am unable to made bold within the monospace block above on the final output:

CONTROL_USB_AUTOSUSPEND="0"

AUTOSUSPEND_USBID_BLACKLIST="046d:c52f"

 

Apparently, I am being redundant, but also robust and documented.

 

Step 3: Get your device identifier for your mouse using the USB port.

 

I'm guessing the devide id trick did not exactly work right for me, but maybe it will for you. The config file tells you what manpage gives your more info and the command to get the usb device id. Here is how to get the id.

me@XXX ~ $ lsusb
Bus 002 Device 003: ID 046d:c52f Logitech, Inc. Unifying Receiver
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 004: ID 05ca:18c0 Ricoh Co., Ltd
Bus 001 Device 003: ID 8086:0189 Intel Corp.
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
me@XXX ~ $

As you can see, my device id for my wireless Logitech mouse is: 046d:c52f .

 

Step 4: Try to blacklist the device, and if that doesn't work, you could disable the USB autosuspend feature entirely.

 

For more info: run 'man laptop-mode.conf' or search online for stuff like this: https://fitzcarraldoblog.wordpress.com/2013/02/26/how-to-prevent-a-usb-mouse-auto-suspending-in-linux-when-a-laptops-power-supply-is-disconnected/ .

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...