Jump to content
funtoo forums
  • 0
Sign in to follow this  
radek

upgrade from 1.3 to 1.4 Amd64 mesa problem

Question

emerge -auDN @world --jobs=3 --exclude dev-lang/perl

!!! The ebuild selected to satisfy ">=media-libs/mesa-9.1.6[egl]" has unmet requirements.
- media-libs/mesa-19.1.4::core-gl-kit USE="(X) (drm) (egl) (gbm) (gles1) (gles2) (glvnd) (glx) (llvm) (ocl-icd) (opengl) (shader-cache) (surfaceless) -alternate-path -android -d3d9 -debug -extra-hud -haiku -opencl -pax_kernel -pic (-selinux) -sensors -test -unwind -valgrind -wayland" CPU_FLAGS_X86="avx avx2 -avx512bw -avx512er" VIDEO_CARDS="amdgpu (osmesa) (swrast) -dri3 -gallium-freedreno -gallium-i915 -gallium-imx -gallium-nouveau -gallium-osmesa -gallium-pl111 -gallium-r300 -gallium-r600 -gallium-radeonsi -gallium-swr -gallium-swrast -gallium-tegra -gallium-v3d -gallium-vc4 -gallium-virgl -gallium-vivante -gallium-vmware -i915 -i965 -intel -nouveau -openmax -r100 -r200 -radeon -vaapi -vdpau -virgl -vulkan-amdgpu -vulkan-intel -xa -xvmc"

  The following REQUIRED_USE flag constraints are unsatisfied:
    video_cards_amdgpu? ( video_cards_radeon )

  The above constraints are a subset of the following complete expression:
    d3d9? ( video_cards_gallium-swrast ) opencl? ( llvm any-of ( video_cards_gallium-pl111 video_cards_gallium-radeonsi video_cards_gallium-r300 video_cards_gallium-r600 video_cards_gallium-nouveau video_cards_gallium-freedreno video_cards_gallium-vc4 video_cards_gallium-v3d video_cards_gallium-vivante video_cards_gallium-imx video_cards_gallium-tegra video_cards_gallium-i915 video_cards_gallium-vmware video_cards_gallium-virgl video_cards_gallium-swr ) ) at-most-one-of ( video_cards_i915 video_cards_gallium-i915 ) at-most-one-of ( video_cards_swrast video_cards_gallium-swrast ) at-most-one-of ( video_cards_osmesa video_cards_gallium-osmesa ) video_cards_vulkan-intel? ( video_cards_intel ) video_cards_i915? ( video_cards_intel ) video_cards_i965? ( video_cards_intel ) video_cards_gallium-i915? ( video_cards_intel ) video_cards_r100? ( video_cards_radeon ) video_cards_r200? ( video_cards_radeon ) video_cards_gallium-r300? ( video_cards_radeon ) video_cards_gallium-r600? ( video_cards_radeon ) video_cards_amdgpu? ( video_cards_radeon ) video_cards_vulkan-amdgpu? ( video_cards_radeon ) wayland? ( egl gbm ) video_cards_gallium-swrast? ( llvm ) video_cards_gallium-swr? ( any-of ( cpu_flags_x86_avx cpu_flags_x86_avx2 cpu_flags_x86_avx512er cpu_flags_x86_avx512bw ) ) video_cards_gallium-imx? ( video_cards_gallium-vivante ) video_cards_gallium-tegra? ( video_cards_gallium-nouveau ) video_cards_gallium-r300? ( x86? ( llvm ) amd64? ( llvm ) ) video_cards_gallium-radeonsi? ( llvm egl? ( any-of ( drm surfaceless ) ) ) video_cards_gallium-pl111? ( video_cards_gallium-vc4 ) video_cards_gallium-virgl? ( egl? ( any-of ( drm surfaceless ) ) ) video_cards_gallium-vivante? ( gbm )

(dependency required by "x11-libs/cairo-1.16.0-r3::gnome-kit[opengl]" [ebuild])
(dependency required by "x11-libs/pango-1.42.4-r2::gnome-kit" [ebuild])
(dependency required by "x11-libs/gtk+-2.24.32-r1::gnome-kit" [ebuild])
(dependency required by "x11-themes/gtk-engines-adwaita-3.28::gnome-kit" [ebuild])
 

added to package.use  >=media-libs/mesa-9.1.6 nothing help

Enabled Profiles: ===

        arch: x86-64bit
       build: current
     subarch: amd64-zen
      flavor: desktop
     mix-ins: lxqt
     mix-ins: audio
     mix-ins: gfxcard-amdgpu

 

MAKEOPTS=" -j4"
LINGUAS="pl"
VIDEO_CARDS="vesa amdgpu radeonsi"
USE="gtk"

 

How to resolve probl;em with upgrade from 1.3 to 1.4

 

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

OK i have resolved this problem but now a one i have that

emerge -auDN @world --jobs=3 --exclude dev-lang/perl

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

  (sys-libs/readline-8.0:0/8::core-kit, ebuild scheduled for merge) pulled in by
    >=sys-libs/readline-8.0:0= required by (app-shells/bash-5.0_p7:0/0::core-kit, ebuild scheduled for merge)
    ^^                  ^^^^^^                                                                                                                                                         

  (sys-libs/readline-7.0_p5:0/7::core-kit, installed) pulled in by
    >=sys-libs/readline-4.1:0/7= required by (dev-lang/python-3.6.8:3.6/3.6m::python-kit, installed)
                           ^^^^^                                                                                                        
    (and 6 more with the same problem)

NOTE: Use the '--verbose-conflicts' option to display parents omitted above

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy "=dev-lang/perl-5.28*" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/perl-5.28.2-r1::perl-kit (masked by: exclude option)

(dependency required by "virtual/perl-ExtUtils-MakeMaker-7.340.0::perl-kit" [ebuild])
(dependency required by "dev-perl/XML-NamespaceSupport-1.120.0::perl-kit" [installed])
(dependency required by "dev-perl/XML-SAX-1.0.0::perl-kit" [installed])
(dependency required by "dev-perl/XML-SAX-Expat-0.510.0::perl-kit" [installed])
(dependency required by "dev-perl/XML-Simple-2.250.0::perl-kit" [installed])
(dependency required by "x11-misc/icon-naming-utils-0.8.90-r1::desktop-kit" [installed])
(dependency required by "x11-themes/mate-icon-theme-1.22.1::desktop-kit" [ebuild])
(dependency required by "mate-base/caja-1.22.1::desktop-kit[mate]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
For more information, see the MASKED PACKAGES section in th

Share this post


Link to post
Share on other sites
  • 0

problem resolved

first i removed perl 5.26

then install perl 5.28

and finally emrge -avDUN @ world

i know that is not recommended... i hope everything will be fine

avUDN now is under proces

Share this post


Link to post
Share on other sites
  • 0

ok upgrade from 1.3 to 1.4 is done

After all i have one problem - preserved libs

 GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: sys-libs/readline-8.0
 *  - /lib64/libreadline.so.7
 *  - /lib64/libreadline.so.7.0
 *      used by /usr/bin/js52 (dev-lang/spidermonkey-52.9.1_pre1)
 *      used by /usr/bin/mujs (dev-lang/mujs-1.0.5)
>>> package: x11-libs/libdrm-2.4.98
 *  - /usr/lib64/libdrm_amdgpu.so.1
 *  - /usr/lib64/libdrm_amdgpu.so.1.0.0
 *      used by /usr/lib64/xorg/modules/drivers/amdgpu_drv.so (x11-drivers/xf86-video-amdgpu-18.1.0)
Use emerge @preserved-rebuild to rebuild packages using these libraries
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.

ryzen32200g /home/radek # emerge @preserved-rebuild
Calculating dependencies... done!
[ebuild   R    ] dev-lang/mujs-1.0.5 
[ebuild   R    ] dev-lang/spidermonkey-52.9.1_pre1 
[ebuild   R    ] x11-libs/libdrm-2.4.98  VIDEO_CARDS="amdgpu*" 
[ebuild   R    ] x11-drivers/xf86-video-amdgpu-18.1.0 

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by x11-drivers/xf86-video-amdgpu-18.1.0::xorg-kit
# required by @preserved-rebuild (argument)
>=x11-libs/libdrm-2.4.98 video_cards_amdgpu

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.
ryzen32200g /home/radek # 
 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...