Jump to content
funtoo forums
  • 0
Sign in to follow this  
romikb

1.4 with video mix-ins on intel works bad

Question

I have a PC connected to a monitor with dvi cable.

With 1.3 release on remote reboot (monitor in power safe mode) after boot I have worked X in 1080 resolution.

After upgrading to 1.4 and setting mix-ins: gfxcard-intel on reboot I have only 640x480.

I try to make a custom config:

Section "Device"
    Identifier     "Card0"
    Driver         "intel"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
EndSection

but X not start with it:

[     9.779]
X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
[     9.780] Build Operating System: Linux 4.19.37_p5-r1-debian-sources-lts x86_64 Gentoo
[     9.780] Current Operating System: Linux server 4.19.37_p5-r1-debian-sources-lts #1 SMP Wed Aug 14 10:19:57 EET 2019 x86_64
[     9.780] Kernel command line: BOOT_IMAGE=/kernel-debian-sources-lts-x86_64-4.19.37_p5-r1 nomodeset real_root=/dev/sda3 rootfst
[     9.780] Build Date: 14 August 2019  11:56:11AM
[     9.780]
[     9.780] Current version of pixman: 0.34.0
[     9.780]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[     9.780] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     9.780] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug 14 13:26:48 2019
[     9.781] (==) Using config file: "/etc/X11/xorg.conf"
[     9.781] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     9.781] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     9.782] (==) No Layout section.  Using the first Screen section.
[     9.782] (**) |-->Screen "Screen0" (0)
[     9.782] (**) |   |-->Monitor "<default monitor>"
[     9.783] (**) |   |-->Device "Card0"
[     9.783] (==) No monitor specified for screen "Screen0".
        Using a default monitor configuration.
[     9.783] (==) Automatically adding devices
[     9.783] (==) Automatically enabling devices
[     9.783] (==) Automatically adding GPU devices
[     9.783] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     9.787] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/OTF/,
        /usr/share/fonts/Type1/,
        /usr/share/fonts/100dpi/,
        /usr/share/fonts/75dpi/
[     9.787] (==) ModulePath set to "/usr/lib64/xorg/modules"
[     9.787] (II) The server relies on udev to provide the list of input devices.
        If no devices become available, reconfigure udev or disable AutoAddDevices.
[     9.787] (II) Loader magic: 0x562ce7822c40
[     9.787] (II) Module ABI versions:
[     9.787]    X.Org ANSI C Emulation: 0.4
[     9.787]    X.Org Video Driver: 24.0
[     9.787]    X.Org XInput driver : 24.1
[     9.787]    X.Org Server Extension : 10.0
[     9.789] (--) PCI: (0@0:2:0) 8086:0152:1458:d000 rev 9, Mem @ 0xf7400000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
[     9.790] (--) PCI:*(1@0:0:0) 10de:0fc6:1458:3553 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432
[     9.790] (II) LoadModule: "glx"
[     9.791] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[     9.802] (II) Module glx: vendor="X.Org Foundation"
[     9.802]    compiled for 1.20.5, module version = 1.0.0
[     9.802]    ABI class: X.Org Server Extension, version 10.0
[     9.802] (II) LoadModule: "intel"
[     9.802] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
[     9.804] (II) Module intel: vendor="X.Org Foundation"
[     9.804]    compiled for 1.20.5, module version = 2.99.917
[     9.804]    Module class: X.Org Video Driver
[     9.804]    ABI class: X.Org Video Driver, version 24.0
[     9.804] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
        i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
        915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
        Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
        GM45, 4 Series, G45/G43, Q45/Q43, G41, B43
[     9.804] (II) intel: Driver for Intel(R) HD Graphics
[     9.804] (II) intel: Driver for Intel(R) Iris(TM) Graphics
[     9.804] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics
[     9.804] (++) using VT number 7

[     9.805] (EE) No devices detected.
[     9.805] (EE)
Fatal server error:
[     9.805] (EE) no screens found(EE)
[     9.805] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[     9.805] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     9.805] (EE)
[     9.806] (EE) Server terminated with error (1). Closing log file.

How can I configure X to have a 1080 resolution on remote reboot in 1.4?

CPU: Intel Core i3-3240 with Intel HD Graphics 2500

# emerge --info
Portage 2.3.68 (python 3.7.3-final-0, funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-9.1.1, glibc-2.29-r2, 4.19.37_p5-r1-debian-sources-lts x86_64)
=================================================================
System uname: Linux-4.19.37_p5-r1-debian-sources-lts-x86_64-Intel-R-_Core-TM-_i3-3240_CPU_@_3.40GHz-with-gentoo-2.2.2
KiB Mem:     8051124 total,   6474968 free
KiB Swap:    2097148 total,   2097148 free
Timestamp of repository dotnet: Tue, 13 Aug 2019 03:28:23 +0000
Head commit of repository dotnet: afcd036f386dabea8829117cc7635b0a5926083a

sh bash 5.0_p7
ld GNU ld (Gentoo 2.32 p2) 2.32.0
app-shells/bash:          5.0_p7::core-kit
dev-java/java-config:     2.2.0-r4::java-kit
dev-lang/perl:            5.28.0::perl-kit
dev-lang/python:          2.7.15::python-kit, 3.7.3::python-kit
dev-util/cmake:           3.14.5::core-kit
sys-apps/baselayout:      2.2.2::core-kit
sys-apps/openrc:          0.41.2::core-kit
sys-apps/sandbox:         2.17::core-kit
sys-devel/autoconf:       2.13-r1::core-kit, 2.69-r4::core-kit
sys-devel/automake:       1.11.6-r3::core-kit, 1.14.1-r2::core-kit, 1.16.1-r1::core-kit
sys-devel/binutils:       2.32-r1::core-kit
sys-devel/gcc:            9.1.1-r8::core-kit
sys-devel/gcc-config:     2.0::core-kit
sys-devel/libtool:        2.4.6-r5::core-kit
sys-devel/make:           4.2.1-r4::core-kit
sys-kernel/linux-headers: 4.14::core-kit (virtual/os-headers)
sys-libs/glibc:           2.29-r2::core-kit
Repositories:

nokit
    location: /var/git/meta-repo/kits/nokit
    masters: core-kit
    priority: -500

RomikB
    location: /usr/local/portage
    masters: core-kit
    priority: 0

dotnet
    location: /var/db/repos/dotnet
    sync-type: git
    sync-uri: https://github.com/gentoo-mirror/dotnet.git
    masters: core-kit

core-gl-kit
    location: /var/git/meta-repo/kits/core-gl-kit
    masters: core-kit
    priority: 1

core-hw-kit
    location: /var/git/meta-repo/kits/core-hw-kit
    masters: core-kit
    priority: 1

core-kit
    location: /var/git/meta-repo/kits/core-kit
    priority: 1
    aliases: gentoo

core-server-kit
    location: /var/git/meta-repo/kits/core-server-kit
    masters: core-kit
    priority: 1

core-ui-kit
    location: /var/git/meta-repo/kits/core-ui-kit
    masters: core-kit
    priority: 1

desktop-kit
    location: /var/git/meta-repo/kits/desktop-kit
    masters: core-kit
    priority: 1

dev-kit
    location: /var/git/meta-repo/kits/dev-kit
    masters: core-kit
    priority: 1

editors-kit
    location: /var/git/meta-repo/kits/editors-kit
    masters: core-kit
    priority: 1

games-kit
    location: /var/git/meta-repo/kits/games-kit
    masters: core-kit
    priority: 1

gnome-kit
    location: /var/git/meta-repo/kits/gnome-kit
    masters: core-kit
    priority: 1

haskell-kit
    location: /var/git/meta-repo/kits/haskell-kit
    masters: core-kit
    priority: 1

java-kit
    location: /var/git/meta-repo/kits/java-kit
    masters: core-kit
    priority: 1

kde-kit
    location: /var/git/meta-repo/kits/kde-kit
    masters: core-kit
    priority: 1

lang-kit
    location: /var/git/meta-repo/kits/lang-kit
    masters: core-kit
    priority: 1

lisp-scheme-kit
    location: /var/git/meta-repo/kits/lisp-scheme-kit
    masters: core-kit
    priority: 1

llvm-kit
    location: /var/git/meta-repo/kits/llvm-kit
    masters: core-kit
    priority: 1

media-kit
    location: /var/git/meta-repo/kits/media-kit
    masters: core-kit
    priority: 1

ml-lang-kit
    location: /var/git/meta-repo/kits/ml-lang-kit
    masters: core-kit
    priority: 1

net-kit
    location: /var/git/meta-repo/kits/net-kit
    masters: core-kit
    priority: 1

perl-kit
    location: /var/git/meta-repo/kits/perl-kit
    masters: core-kit
    priority: 1

python-kit
    location: /var/git/meta-repo/kits/python-kit
    masters: core-kit
    priority: 1

python-modules-kit
    location: /var/git/meta-repo/kits/python-modules-kit
    masters: core-kit
    priority: 1

ruby-kit
    location: /var/git/meta-repo/kits/ruby-kit
    masters: core-kit
    priority: 1

rust-kit
    location: /var/git/meta-repo/kits/rust-kit
    masters: core-kit
    priority: 1

science-kit
    location: /var/git/meta-repo/kits/science-kit
    masters: core-kit
    priority: 1

security-kit
    location: /var/git/meta-repo/kits/security-kit
    masters: core-kit
    priority: 1

text-kit
    location: /var/git/meta-repo/kits/text-kit
    masters: core-kit
    priority: 1

xfce-kit
    location: /var/git/meta-repo/kits/xfce-kit
    masters: core-kit
    priority: 1

xorg-kit
    location: /var/git/meta-repo/kits/xorg-kit
    masters: core-kit
    priority: 1

Installed sets: @kernel
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=ivybridge -O2 -pipe -mno-aes -mno-rdrnd"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/easy-rsa /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=ivybridge -O2 -pipe -mno-aes -mno-rdrnd"
DISTDIR="/var/cache/portage/distfiles"
FEATURES="assume-digests binpkg-docompress binpkg-dostrip binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles ipc-sandbox merge-sync multilib-strict network-sandbox news parallel-fetch pid-sandbox preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=ivybridge -O2 -pipe"
GENTOO_MIRRORS="https://fastpull-us.funtoo.org"
INSTALL_MASK="/etc/systemd/ /usr/lib/systemd/ /lib/systemd/"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
PKGDIR="/var/cache/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
USE="X a52 aac acl alsa amd64 apng berkdb bluray bzip2 cdda cddb cdio cdr cracklib crypt curl cxx dbus dnssd dri dts dvd dvdr dvdread elogind encode exif faac faad ffmpeg flac gdbm gif glvnd gpm gstreamer gtk ico iconv icu ieee1394 introspection ios ipod ipv6 jpeg jpeg2k lame libass libguess libmpeg2 libnotify lock mad matroska mjpeg mmx modules mp3 mpeg mtp mudflap ncurses nls nptl nsplugin ogg opengl openmp pam pcre pdf png policykit postproc pppd python quicktime readline resolvconf sdl sdl1 session sndfile sse sse2 ssl startup-notification svg taglib tcpd theora thunar tiff truetype twolame udev unicode v4l vaapi vdpau vorbis vpx wav wavpack webp win32codecs wmf x264 x265 xa xattr xml xvid xvmc zeroconf zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="avx f16c mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php7-3" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_7" PYTHON_TARGETS="python3_7 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby25 ruby26" USERLAND="GNU" VIDEO_CARDS="intel vulkan-intel dri3 i965 i915 fbdev osmesa swrast vaapi vdpau xa xvmc" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, ENV_UNSET, LC_ALL, LINGUAS, MAKEOPTS, PORTAGE_BINHOST, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS

 

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Remove nomodeset from boot loader kernel command line and reboot.

Kernel command line: BOOT_IMAGE=/kernel-debian-sources-lts-x86_64-4.19.37_p5-r1 nomodeset real_root=/dev/sda3 rootfst

If that doesn't help check dmesg for graphics hardware error messages.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, cardinal said:

Remove nomodeset from boot loader kernel command line and reboot.

After removing "nomodeset" without custom config X start and work as needed. Thank you.

 

But with custom config X still not starting, how can I fix this?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...