Jump to content
funtoo forums
minou666

4k screen problem

Recommended Posts

While the kernel is booting the whole screen is used but after the login only the top half of the screen is used.

In both cases the text is so small that it is extremenly hard to read.

How do we fix this issue and the fact that you would need and the display so we don't need magnifying lenses to be able to see what is displayed?

 

My linux pc is a Ryzen 7 board with 32GB of RAM, RX580 video card,  RAM and 20TB of hard disk space

Michel

 

Share this post


Link to post
Share on other sites

So when the system boots, grub will display, and it will potentially set a resolution. Is the grub resolution OK? If you are using UEFI, it may be too small at GRUB. This is important to know because we need to figure out at what point it should be fixed 🙂 If it is getting really small during boot, this is due to kernel modesetting which is something different.

If grub is at a decent resolution, then booting with the "nomodeset" kernel parameter will prevent things from getting too small at boot. You will need modesetting for many graphics drivers, but this is a quick fix to avoid using a magnifying glass when you are setting up your system 🙂

Share this post


Link to post
Share on other sites

It looks perfect during boot except that the text is small, about the same size as on arch linux and Fedora 29. I know I can increase the text later on so that doesn't bother me quite as much as the half screen. It is hard to pinpoint exactly when the problem occurs but it appears to be at the point right after the kernel is loaded, perhaps as it reads inittab.

I does have time to show stuff before switching to the login. Which script clears the screen before the login prompt show up? Maybe removing the clear screen would help see where the switch is made, assuming that the text shown would not exceed that half screen.

 

I did remove the nomodeset since the text is always too big when leave it as I have seen with my Odroid H2. I haven't tried the H2 with my 4k monitor yet, I plan to connect to my 4k TV later on.

I will likely have similar issues. On my Odroid H2 I could not get xorg to work without removing the nomodeset item.

 

I do a lot of work on the command line so I do not want huge characters on the screen. I use 28 inches monitor to get more text, not to emulate a pet or vic20 style resolution.

Right now I go around the small text problems using ssh on my mac and my odroid H2. My mac has a 28 inch 5k display. That works good to setup funtoo but when I do embedded Linux stuff I will want to do that work using my 4k monitor.

 

Michel

Share this post


Link to post
Share on other sites

I've noticed the same issue with Fedora 29

Graphic mode works ok except that when using a second monitor that is 1080,  keeping the first monitor as 4k creates issues.

When characters are set to be viewable on the 4k monitor the characters are huge on the 1080 monitor.

It looks like the solution is to get another 4k monitor. Is there a way to get them to work.

 

Last I tried a compromise, slickedit would appear to crash,  when I set the 4k display to 1080 it turned out that slickedit was opening a window outside of the viewing area on the second display.

That was with a mate desktop, I haven't tried on my new install which I am compiling kde-plasma.

It looks like it wasn't returned real size for the second screen and assumed that they were both 4k.

Michel

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...