Jump to content
funtoo forums
  • 0
hogsdill

Problem with Grub Install and Boot Update

Question

I screwed up my boot partition the other day and had to create the filesystem again and reconfigure grub. I believe that I have everything setup like it was, but for some reason I cannot get it to boot.

 

When I ran the grub-install command, everything seemed to work.

(chroot) sysresccd / # grub-install --no-floppy /dev/sda
Installation finished. No error reported.

But when I ran boot-update, I got an error message that I haven't seen before. Any one know how to fix this? I searched via Google, but didn't see anything definitive.

(chroot) sysresccd / # boot-update
Traceback (most recent call last):
  File "/sbin/boot-update", line 15, in <module>
    import funtoo.boot.config
ImportError: No module named funtoo.boot.config

Here is my grub.cfg

set timeout=10

  insmod part_msdos
  insmod ext2
  set root=(hostdisk//dev/sda,msdos1)
  search --no-floppy --fs-uuid --set eb03fe8e-058d-4e83-83e5-4625800511f8
if loadfont /grub/unifont.pf2; then
   set gfxmode=1440x900
   insmod gfxterm
   insmod vbe
   terminal_output gfxterm
fi

set menu_color_normal=cyan/black
set menu_color_highlight=black/cyan

menuentry "Funtoo Linux - Gentoo Kernel 3.14.5 - bzImage_linux-3.14.5-gentoo" {
  insmod part_msdos
  insmod ext2
  set root=(hostdisk//dev/sda,msdos1)
  search --no-floppy --fs-uuid --set eb03fe8e-058d-4e83-83e5-4625800511f8
  linux /bzImage_linux-3.14.5-gentoo rootfstype=ext4 root=/dev/sda3
  set gfxpayload=text
}
set default=0

Here is my /etc/fstab. Pretty simple setup.

# <fs>		<mountpoint>		<type>		<opts>		<dump/pass>

/dev/sda1	/boot			ext4		noauto,noatime	1 2
/dev/sda2	none			swap		sw		0 0
/dev/sda3	/			ext4		noatime		0 1

And also /etc/boot.conf

boot {
	generate grub
	default "Funtoo Linux - Gentoo Kernel 3.14.5" 
	timeout 10 
}

display {
	gfxmode 1440x900
	#background /boot/
	}

color {
	normal cyan/black
	highlight black/cyan
	}

"Funtoo Linux - Gentoo Kernel 3.14.5" {
	kernel bzImage_linux-3.14.5-gentoo 
}

"Funtoo Linux genkernel" {
	kernel kernel[-v]
	initrd initramfs[-v]
	params += real_root=auto 
} 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...