Jump to content
funtoo forums
  • 0
Sign in to follow this  
tbill

USE flags? Why so necessary?

Question

Disclaimer:  I used Gentoo back when it was still v.1.0 and drobbins still administered it. Used it for some years.  (Sort of the perpetual newb!)

Came over to Funtoo "just 'cuz" and built a nice, usable install with kde.  Enjoyed it for a couple of years, then noticed that an upgrade was available.  I upgraded, but the internet connection was borked following the upgrade; I figured the easiest (well, maybe not the easiest!) job would be to do a complete reinstall.  So I did.  Everything has gone well EXCEPT for the re-install of KDE.  The USE flags are killing me!  I cannot find an acceptable combo that satisfies Portage/emerge to let me install the set.  I know that KDE developers work to make ALL their apps play nice with one another, so why are there so many conflicts that, supposedly, require specific USE flags to install properly?  It's not like the use of USE flags is universal among Linux distros!  So far as I know,  Gentoo and Funtoo are unique among distros in using them, yet KDE doesn't build their apps predicated upon the incorporation of USE flags to complicate the issue!  Are the specific USE flag requirements for a package set by Gentoo/Funtoo developers?  Any workarounds?

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1

When I did a fresh Funtoo 1.3 install on my desktop PC I just set my profile with epro and installed the KDE meta package and it worked (nearly) flawlessly.  I did something like this:

 

#epro flavor desktop
	# epro mix-ins kde-plasma-5-new
	# epro mix-ins no-systemd
	# epro mix-ins gfxcard-nvidia
	# emerge -vauND --with-bdeps=y @world
	# (say yes to any USE flag changes)
	# dispatch-conf
	# emerge -vauND --with-bdeps=y @world
	#emerge -va xorg-server nvidia-drivers nvidia-settings
	# emerge -va plasma-meta
	# (say yes to any USE flag changes)
	# dispatch-conf
	# emerge -va plasma-meta

I have zero USE flags set in my make.conf and in package.use I only have what portage added.

Share this post


Link to post
Share on other sites
  • 0

Wow!  Complete answer!!  I commented out my USE flags in make.conf; didn't help.  I'll write down your suggestions, try them, and report.  Thanks a million!  One more question:  I'm not familiar with "dispatch-conf".  Got a short explanation?  Or can you point me to one, long or short?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×