Jump to content
funtoo forums
  • 0
Sign in to follow this  
johnnygarb

dev-lang/rust-1.30 net-kit failed Build requirements not met | There is NOT at least 4 GiB RAM

Question

Hi everyone.

 i'm trying to update my laptop and i got this error:

>>> Running pre-merge checks for dev-lang/rust-1.30.1-r1
 * Checking for at least 4 GiB RAM ...                                                                                                                [ !! ]
 * There is NOT at least 4 GiB RAM
 * Checking for at least 7 GiB disk space at "/var/tmp/portage/dev-lang/rust-1.30.1-r1/temp" ...                                                      [ ok ]
 *
 * Space constraints set in the ebuild were not met!
 * The build will most probably fail, you should enhance the space
 * as per failed tests.
 *
 * ERROR: dev-lang/rust-1.30.1-r1::net-kit failed (pretend phase):
 *   Build requirements not met!

 

but i have  4gb ram  and  3gb swap.

i appreciate some advice

 

 

 

 

emerge -pqv.txt

emerge --info.txt

error.txt

build.log

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
On 11/24/2018 at 1:45 AM, cardinal said:

Can rust-bin the  pre-compiled binary version that doesn't have the free space requirements be substituted for rust?

thank you cardinal.  i did:

emerge -av   rust-bin

that worked for me.  now i can continue updating

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×