Jump to content
funtoo forums
  • 0
Sign in to follow this  
lazlo.vii

LXD no longer starting via openrc, issue with /usr/libexec/lxd

Question

I don't know what I did, but what ever it was it wasn't good.  I had to shut it down my server and move it to clean the floor and after booting it back up I noticed my containers were not running.

 

Running /etc/init.d/lxd start:

* Starting lxd service ...
 * start-stop-daemon: /usr/libexec/lxd does not exist                                     [ !! ]
 * ERROR: lxd failed to start

I tried "rc-update del lxd default" and rebooted then "rc-update add lxd default && openrc"

Still had the same issue.

So then I tried "mkdir /usr/libexec/lxd && openrc"  and I got:

 

* Starting lxd service ...                                                               [ ok ]
	lxc list
Error: Get http://unix.socket/1.0: dial unix /var/lib/lxd/unix.socket: connect: no such file or directory

tail -f /var/log/syslog showed me this:

/etc/init.d/lxd[21723]: ERROR: lxd failed to start
/etc/init.d/lxd[21771]: start-stop-daemon: failed to exec `/usr/libexec/lxd': Permission denied

 

If I start lxd as root with "lxd --group lxd" I can get my containers but I have to do it in a tmux session so I can leave it running after logging out of ssh.  Doing this I am unable to tell any difference from the way my server used to start lxd via openrc.

What ever I did wrong was done days or maybe weeks ago.  Did I miss configure something?  Did I use the wrong option in etc-update?  I have tried recompiling lxd, lxc, lxcfs, and cgmanager but it didn't change anything.  I am at a loss.  What should I look at next?

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

I rolled my filesystem back to a snapshot taken on Oct 8.  This was before the update that installed LXD 3.6 and everything started correctly from openrc.  Now I just need to install the updates from the past month and hope the issue doesn't resurface.

Share this post


Link to post
Share on other sites
  • 0

OK, I have updated and the issue has not come back.  Now I just need to recreate a few containers and restore their data (three cheers for backups) which will be a pain in the ass but at least it's working again. 

Share this post


Link to post
Share on other sites
  • 0
lxd import
Description:
  Import existing containers

  This command is mostly used for disaster recovery. It lets you attempt
  to recreate all database entries for containers that LXD no longer knows
  about.

  To do so, you must first mount your container storage at the expected
  path inside the storage-pools directory. Once that's in place,
  `lxd import` can be called for each individual container.

Usage:
  lxd import <container name> [flags]

Flags:
  -f, --force   Force the import (override existing data or partial restore)

Global Flags:
  -d, --debug     Show all debug messages
  -h, --help      Print help
      --logfile   Path to the log file
      --trace     Log tracing targets
  -v, --verbose   Show all information messages
      --version   Print version number

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×