Jump to content
funtoo forums
  • 0
Sign in to follow this  
tommy3001

ERROR: media-libs/libharu-2.3.0-r2::media-kit failed

Question

libharu is a requirement of freecad...

The Output from

 emerge libharu

is:

* ERROR: media-libs/libharu-2.3.0-r2::media-kit failed (prepare phase):
 *   patch -p1  failed with /var/tmp/portage/media-libs/libharu-2.3.0-r2/files/libharu-2.3.0-1-Included-necessary-char-widths-in-generated-PDF.patch
 * 
 * Call stack:
 *               ebuild.sh, line   92:  Called src_prepare
 *             environment, line 3662:  Called cmake-utils_src_prepare
 *             environment, line  870:  Called _cmake_execute_optionally 'src_prepare'
 *             environment, line  306:  Called enable_cmake-utils_src_prepare
 *             environment, line 1340:  Called default_src_prepare
 *      phase-functions.sh, line  932:  Called __eapi6_src_prepare
 *             environment, line  237:  Called eapply '/var/tmp/portage/media-libs/libharu-2.3.0-r2/files/libharu-2.3.0-1-Included-necessary-char-widths-in-generated-PDF.patch' '/var/tmp/portage/media-libs/libharu-2.3.0-r2/files/libharu-2.3.0-2-Avoid-issue-with-libtiff-duplicate-symbols.patch' '/var/tmp/portage/media-libs/libharu-2.3.0-r2/files/libharu-2.3.0-3-cmake-fixes.patch' '/var/tmp/portage/media-libs/libharu-2.3.0-r2/files/libharu-2.3.0-4-Add-support-for-free-form-triangle-Shading-objects.patch'
 *             environment, line 1052:  Called _eapply_patch '/var/tmp/portage/media-libs/libharu-2.3.0-r2/files/libharu-2.3.0-1-Included-necessary-char-widths-in-generated-PDF.patch'
 *             environment, line  990:  Called __helpers_die 'patch -p1  failed with /var/tmp/portage/media-libs/libharu-2.3.0-r2/files/libharu-2.3.0-1-Included-necessary-char-widths-in-generated-PDF.patch'
 *   isolated-functions.sh, line  121:  Called die
 * The specific snippet of code:
 *   		die "$@"

 

emerge_info_libharu.txt

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0


...there is is a missing information, sorry.... this ebuild was copied from the gentoo repository. The reason was, that I got the message during the installation of opencascade that i need the following version of libharu as dependancy, but it is not included in the funtoo repo:

 

media-libs/libharu-2.3.0-r2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×