Jump to content
funtoo forums
  • 0
walterw

emerge --newuse -uD world - mips-sources problem?

Question

I am attempting to update my systems and for whatever reason, when running:

 

emerge --newuse -uD world -vp

 

mips-sources is complaining of eapi7-ver: EAPI=5 not supported.  I don't have mips-sources installed and I'm on an x86/64 system.


 

Calculating dependencies / * ERROR: sys-kernel/mips-sources-4.13.16::nokit failed (depend phase):
 *   eapi7-ver: EAPI=5 not supported
 * 
 * Call stack:
 *                     ebuild.sh, line 603:  Called source '/var/git/meta-repo/kits/nokit/sys-kernel/mips-sources/mips-sources-4.13.16.ebuild'
 *   mips-sources-4.13.16.ebuild, line  27:  Called inherit 'eapi7-ver' 'eutils' 'kernel-2'
 *                     ebuild.sh, line 294:  Called __qa_source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass'
 - *                     ebuild.sh, line  79:  Called source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass'
 *              eapi7-ver.eclass, line  62:  Called die
 * The specific snippet of code:
 *           die "${ECLASS}: EAPI=${EAPI:-0} not supported";;
 * 
 * If you need support, post the output of `emerge --info '=sys-kernel/mips-sources-4.13.16::nokit'`,
 * the complete build log and the output of `emerge -pqv '=sys-kernel/mips-sources-4.13.16::nokit'`.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/var/tmp/portage/sys-kernel/mips-sources-4.13.16/work/linux--20171007'
 | * ERROR: sys-kernel/mips-sources-4.9.75::nokit failed (depend phase):
 *   eapi7-ver: EAPI=5 not supported
 * 
 * Call stack:
 *                    ebuild.sh, line 603:  Called source '/var/git/meta-repo/kits/nokit/sys-kernel/mips-sources/mips-sources-4.9.75.ebuild'
 *   mips-sources-4.9.75.ebuild, line  27:  Called inherit 'eapi7-ver' 'eutils' 'kernel-2'
 *                    ebuild.sh, line 294:  Called __qa_source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass'
 *                    ebuild.sh, line  79:  Called source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass'
 *             eapi7-ver.eclass, line  62:  Called die
 * The specific snippet of code:
 *           die "${ECLASS}: EAPI=${EAPI:-0} not supported";;
 * 
 * If you need support, post the output of `emerge --info '=sys-kernel/mips-sources-4.9.75::nokit'`,
 * the complete build log and the output of `emerge -pqv '=sys-kernel/mips-sources-4.9.75::nokit'`.
 - * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/var/tmp/portage/sys-kernel/mips-sources-4.9.75/work/linux--20161216'
 \ * ERROR: sys-kernel/mips-sources-4.4.110::nokit failed (depend phase):
 *   eapi7-ver: EAPI=5 not supported
 * 
 * Call stack:
 *                     ebuild.sh, line 603:  Called source '/var/git/meta-repo/kits/nokit/sys-kernel/mips-sources/mips-sources-4.4.110.ebuild'
 *   mips-sources-4.4.110.ebuild, line  27:  Called inherit 'eapi7-ver' 'eutils' 'kernel-2'
 *                     ebuild.sh, line 294:  Called __qa_source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass'
 *                     ebuild.sh, line  79:  Called source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass'
 *              eapi7-ver.eclass, line  62:  Called die
 * The specific snippet of code:
 *           die "${ECLASS}: EAPI=${EAPI:-0} not supported";;
 * 
 * If you need support, post the output of `emerge --info '=sys-kernel/mips-sources-4.4.110::nokit'`,
 * the complete build log and the output of `emerge -pqv '=sys-kernel/mips-sources-4.4.110::nokit'`.
 * Working directory: '/usr/lib64/python2.7/site-packages'
 * S: '/var/tmp/portage/sys-kernel/mips-sources-4.4.110/work/linux--20160123'
... done!

Total: 0 packages, Size of downloads: 0 KiB

WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

dev-python/urllib3:0

  dev-python/urllib3-1.23:0/0::python-modules-kit, ebuild scheduled for merge conflicts with
    <dev-python/urllib3-1.23[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/elasticsearch-py-6.3.0:0/0::python-modules-kit, installed

 

Now, the interesting thing is, I only get this error when updating systems with ZFS, but those ebuilds don't appear to have changed recently.

I'm running the default kits, but I also tried updating to 1.2 where possible, but that didn't seem to make any difference.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

The bug report is marked as closed but the task not finished yet, as you can see by the comments in the bug. It still needs some work:

Quote
drobbins added a comment - 2 days ago

OK. The eapi7-ver.eclass was created to TEST eapi 7 but I guess that gentoo is not doing a good job cleaning up after themselves so I will take care of this in a bit.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...