Jump to content
funtoo forums

Search the Community

Showing results for tags 'mips-sources'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 1 result

  1. I am attempting to update my systems and for whatever reason, when running: emerge --newuse -uD world -vp mips-sources is complaining of eapi7-ver: EAPI=5 not supported. I don't have mips-sources installed and I'm on an x86/64 system. Calculating dependencies / * ERROR: sys-kernel/mips-sources-4.13.16::nokit failed (depend phase): * eapi7-ver: EAPI=5 not supported * * Call stack: * ebuild.sh, line 603: Called source '/var/git/meta-repo/kits/nokit/sys-kernel/mips-sources/mips-sources-4.13.16.ebuild' * mips-sources-4.13.16.ebuild, line 27: Called inherit 'eapi7-ver' 'eutils' 'kernel-2' * ebuild.sh, line 294: Called __qa_source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass' - * ebuild.sh, line 79: Called source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass' * eapi7-ver.eclass, line 62: Called die * The specific snippet of code: * die "${ECLASS}: EAPI=${EAPI:-0} not supported";; * * If you need support, post the output of `emerge --info '=sys-kernel/mips-sources-4.13.16::nokit'`, * the complete build log and the output of `emerge -pqv '=sys-kernel/mips-sources-4.13.16::nokit'`. * Working directory: '/usr/lib64/python2.7/site-packages' * S: '/var/tmp/portage/sys-kernel/mips-sources-4.13.16/work/linux--20171007' | * ERROR: sys-kernel/mips-sources-4.9.75::nokit failed (depend phase): * eapi7-ver: EAPI=5 not supported * * Call stack: * ebuild.sh, line 603: Called source '/var/git/meta-repo/kits/nokit/sys-kernel/mips-sources/mips-sources-4.9.75.ebuild' * mips-sources-4.9.75.ebuild, line 27: Called inherit 'eapi7-ver' 'eutils' 'kernel-2' * ebuild.sh, line 294: Called __qa_source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass' * ebuild.sh, line 79: Called source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass' * eapi7-ver.eclass, line 62: Called die * The specific snippet of code: * die "${ECLASS}: EAPI=${EAPI:-0} not supported";; * * If you need support, post the output of `emerge --info '=sys-kernel/mips-sources-4.9.75::nokit'`, * the complete build log and the output of `emerge -pqv '=sys-kernel/mips-sources-4.9.75::nokit'`. - * Working directory: '/usr/lib64/python2.7/site-packages' * S: '/var/tmp/portage/sys-kernel/mips-sources-4.9.75/work/linux--20161216' \ * ERROR: sys-kernel/mips-sources-4.4.110::nokit failed (depend phase): * eapi7-ver: EAPI=5 not supported * * Call stack: * ebuild.sh, line 603: Called source '/var/git/meta-repo/kits/nokit/sys-kernel/mips-sources/mips-sources-4.4.110.ebuild' * mips-sources-4.4.110.ebuild, line 27: Called inherit 'eapi7-ver' 'eutils' 'kernel-2' * ebuild.sh, line 294: Called __qa_source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass' * ebuild.sh, line 79: Called source '/var/git/meta-repo/kits/core-kit/eclass/eapi7-ver.eclass' * eapi7-ver.eclass, line 62: Called die * The specific snippet of code: * die "${ECLASS}: EAPI=${EAPI:-0} not supported";; * * If you need support, post the output of `emerge --info '=sys-kernel/mips-sources-4.4.110::nokit'`, * the complete build log and the output of `emerge -pqv '=sys-kernel/mips-sources-4.4.110::nokit'`. * Working directory: '/usr/lib64/python2.7/site-packages' * S: '/var/tmp/portage/sys-kernel/mips-sources-4.4.110/work/linux--20160123' ... done! Total: 0 packages, Size of downloads: 0 KiB WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: dev-python/urllib3:0 dev-python/urllib3-1.23:0/0::python-modules-kit, ebuild scheduled for merge conflicts with <dev-python/urllib3-1.23[python_targets_python2_7(-),python_targets_python3_4(-),-python_single_target_pypy(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)] required by dev-python/elasticsearch-py-6.3.0:0/0::python-modules-kit, installed Now, the interesting thing is, I only get this error when updating systems with ZFS, but those ebuilds don't appear to have changed recently. I'm running the default kits, but I also tried updating to 1.2 where possible, but that didn't seem to make any difference.
×
×
  • Create New...