Jump to content
  • 0

ruby blocking kde-plasma


mauricev
 Share

Question

In trying to emerge kde-plasma, I am getting this

 

Oops! Conflicts have been encountered:

>>> dev-lang/ruby-2.4.3:2.4/2.4::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-5.1.0[ruby_targets_ruby24]
>>> dev-lang/ruby-2.2.9:2.2/2.2::ruby-kit, ebuild scheduled for merge, wants >=dev-ruby/rdoc-4.0.1[ruby_targets_ruby22]

My candidates are:

>>> dev-ruby/rdoc-5.1.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 but not IUSE ruby_targets_ruby22
>>> dev-ruby/rdoc-4.3.0:0/0::ruby-kit, ebuild scheduled for merge has SLOT 0/0 and IUSE ruby_targets_ruby22

 

Link to comment
Share on other sites

Recommended Posts

  • 0
8 hours ago, no1livz4ever said:

What did you exactly set? Did you set USE per package or globally? I’ve also encountered exactly the same problem and cannot get past it ... it would be great if you coukd post your USE settings for rdoc. Tnx

Edit your make.conf file, and add "-rdoc" in your USE flags. See the line of my make.conf that's define my use flags:

USE="-rdoc -aes mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3 binary"

Here this works fine to resolve this problem

Link to comment
Share on other sites

  • 0

Up until this step (emerging plasma-meta) everything went very smooth, installed X server, startx working, evdev input ok, during boot no errors, emerge —depclean nothing, nothing to update, i’ve synced ego few times ... cannot get past this error. Pretty frustrating because it took me almost a whole day to get to this step ...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...