Jump to content
funtoo forums
  • 0
Sign in to follow this  
delyas

Strange behavior with Firefox & Clementine after Funtoo 1.2 Update

Question

Hi,

After the release of the Funtoo 1.2 Update, I upgraded my system with gcc-6.4.0, before 7.3.1 was unmasked, the same way it is in the announcement.

Since then, Clementine doesn't start the first time after a reboot but launch great the second time but with an overwrited config file in ~/.config/Clementine folder. Since the update, it's also all in English whereas it was in French before. With Firefox, it doesn't take account of my ~/.asoundrc file anymore, so I had to copy it in /etc/asound.conf. In the history library, the time is now at UTC+0 and not at the local time whereas the time is ok system-wide.

I synced my packages with the gcc-7.3.1 update and recompile my whole system (except Firefox because I have the version 59.0.2 installed and the 60.0 need upgraded versions if some packages that are not in meta-repo, which are nss-3.36.1 and nspr-4.19) but the problem is still here. There was some minor glitches too but they disappeared with the whole rebuilt.

I strikethrough some text because I upgraded Firefox and my kernel to a maintained one (4.12.12 -> 4.9.99) and this fixed these issues.

Here is my emerge --info (now updated):

Portage 2.3.24 (python 3.4.6-final-0, funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-7.3.1, glibc-2.26-r6, 4.9.99-gentoo x86_64)
=================================================================
System uname: Linux-4.9.99-gentoo-x86_64-Intel-R-_Core-TM-_i5-2500_CPU_@_3.30GHz-with-gentoo-2.2.2
KiB Mem:     8077876 total,   5370864 free
KiB Swap:          0 total,         0 free
sh bash 4.4_p18
ld GNU ld (Gentoo 2.29.1 p3) 2.29.1
app-shells/bash:          4.4_p18::core-kit
dev-java/java-config:     2.2.0-r3::java-kit
dev-lang/perl:            5.24.0-r3::perl-kit
dev-lang/python:          2.7.14-r2::python-kit, 3.4.6-r1::python-kit
dev-util/cmake:           3.10.1::core-kit
sys-apps/baselayout:      2.2.2::core-kit
sys-apps/openrc:          0.35.0_beta1-r1::core-kit
sys-apps/sandbox:         2.12::core-kit
sys-devel/autoconf:       2.13::core-kit, 2.69-r4::core-kit
sys-devel/automake:       1.13.4-r1::core-kit, 1.15.1-r1::core-kit
sys-devel/binutils:       2.29.1-r1::core-kit
sys-devel/gcc:            7.3.1::core-kit
sys-devel/gcc-config:     1.9.1::core-kit
sys-devel/libtool:        2.4.6-r4::core-kit
sys-devel/make:           4.2.1-r1::core-kit
sys-kernel/linux-headers: 4.14::core-kit (virtual/os-headers)
sys-libs/glibc:           2.26-r6::core-kit
Repositories:

nokit
    location: /var/git/meta-repo/kits/nokit
    masters: core-kit
    priority: -500

core-hw-kit
    location: /var/git/meta-repo/kits/core-hw-kit
    masters: core-kit
    priority: 1

core-kit
    location: /var/git/meta-repo/kits/core-kit
    masters: core-kit
    priority: 1
    aliases: gentoo

desktop-kit
    location: /var/git/meta-repo/kits/desktop-kit
    masters: core-kit
    priority: 1

dev-kit
    location: /var/git/meta-repo/kits/dev-kit
    masters: core-kit
    priority: 1

editors-kit
    location: /var/git/meta-repo/kits/editors-kit
    masters: core-kit
    priority: 1

games-kit
    location: /var/git/meta-repo/kits/games-kit
    masters: core-kit
    priority: 1

gnome-kit
    location: /var/git/meta-repo/kits/gnome-kit
    masters: core-kit
    priority: 1

haskell-kit
    location: /var/git/meta-repo/kits/haskell-kit
    masters: core-kit
    priority: 1

java-kit
    location: /var/git/meta-repo/kits/java-kit
    masters: core-kit
    priority: 1

kde-kit
    location: /var/git/meta-repo/kits/kde-kit
    masters: core-kit
    priority: 1

lang-kit
    location: /var/git/meta-repo/kits/lang-kit
    masters: core-kit
    priority: 1

lisp-scheme-kit
    location: /var/git/meta-repo/kits/lisp-scheme-kit
    masters: core-kit
    priority: 1

llvm-kit
    location: /var/git/meta-repo/kits/llvm-kit
    masters: core-kit
    priority: 1

media-kit
    location: /var/git/meta-repo/kits/media-kit
    masters: core-kit
    priority: 1

ml-lang-kit
    location: /var/git/meta-repo/kits/ml-lang-kit
    masters: core-kit
    priority: 1

net-kit
    location: /var/git/meta-repo/kits/net-kit
    masters: core-kit
    priority: 1

perl-kit
    location: /var/git/meta-repo/kits/perl-kit
    masters: core-kit
    priority: 1

php-kit
    location: /var/git/meta-repo/kits/php-kit
    masters: core-kit
    priority: 1

python-kit
    location: /var/git/meta-repo/kits/python-kit
    masters: core-kit
    priority: 1

ruby-kit
    location: /var/git/meta-repo/kits/ruby-kit
    masters: core-kit
    priority: 1

science-kit
    location: /var/git/meta-repo/kits/science-kit
    masters: core-kit
    priority: 1

security-kit
    location: /var/git/meta-repo/kits/security-kit
    masters: core-kit
    priority: 1

text-kit
    location: /var/git/meta-repo/kits/text-kit
    masters: core-kit
    priority: 1

xfce-kit
    location: /var/git/meta-repo/kits/xfce-kit
    masters: core-kit
    priority: 1

xorg-kit
    location: /var/git/meta-repo/kits/xorg-kit
    masters: core-kit
    priority: 1

ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=sandybridge -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=sandybridge -O2 -pipe"
DISTDIR="/var/cache/portage/distfiles"
EMERGE_DEFAULT_OPTS="--jobs 2 --load-average 1 --with-bdeps=y --keep-going"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync multilib-strict news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-march=sandybridge -O2 -pipe"
GENTOO_MIRRORS="https://fastpull-us.funtoo.org"
INSTALL_MASK="/etc/systemd/ /usr/lib/systemd/ /lib/systemd/"
LANG="fr_FR.utf8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="fr fr_FR en"
MAKEOPTS="-j5"
PKGDIR="/var/cache/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/home/damiatux/.tmp/"
USE="X a52 aac acl alsa amd64 apng berkdb bluray branding bzip2 cdda cddb cdio cdr consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr dvdread encode exif faac faad ffmpeg flac fuse gdbm gif glamor gpm gstreamer gtk gtk3 guile ico iconv icu id3tag ieee1394 introspection ios ipod ipv6 javascript jpeg jpeg2k lame libass libguess libmpeg2 libnotify mad matroska mjpeg mmx modules mp3 mpeg mtp mudflap multilib ncurses nls nptl nsplugin nvidia ogg opengl openmp pam pcre pdf png postproc pppd python quicktime readline resolvconf session sndfile sse sse2 ssl startup-notification svg taglib tcpd theora tiff truetype twolame udev udisks unicode upower v4l vaapi vdpau vorbis vpx wav wavpack webp win32codecs wmf x264 x265 xattr xdg xml xvid zlib" ABI_X86="32 64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="aes avx mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock isync itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf skytraq superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" L10N="fr en" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="fr fr_FR en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6 php7-0" POSTGRES_TARGETS="postgres9_5" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python3_4 python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby22 ruby23 ruby24" USERLAND="GNU" VIDEO_CARDS="nvidia intel i965" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, ENV_UNSET, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS

 

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Cafaia: I don't know how to help, I don't have the same issues. Mine are just Clementine that is now in English and Firefox only displaying the hours at UTC+0.

Palica: Here there are.

For Clementine:

First launch after reboot:

19:05:00.506 WARN  unknown                          QColor::fromHsv: HSV parameters out of range 
Signal de temps-Réel 0

("Signal de temps-réel" means real time signal)

Second lauch (same with the --verbose option):

19:09:29.292 WARN  unknown                          QColor::fromHsv: HSV parameters out of range 
19:09:29.885 WARN  unknown                          QColor::fromHsv: HSV parameters out of range 
19:09:30.406 ERROR unknown                          JSonScanner::yylex - error while reading from io device  
19:09:30.406 ERROR unknown                          json_parser - syntax error found,  forcing abort, Line 1 Column 1

For Firefox:

1526490366971	addons.webextension.2.0@disconnect.me	WARN	Please specify whether you want browser_style or not in your browser_action options.
1526490366972	addons.webextension.https-everywhere-eff@eff.org	WARN	Please specify whether you want browser_style or not in your browser_action options.
Extension error: TypeError: cookies is undefined moz-extension://ed8481b2-bd00-4200-8345-e5a4a0b6e624/js/cookies.js 105
[[Exception stack
addCookiesToDict@moz-extension://ed8481b2-bd00-4200-8345-e5a4a0b6e624/js/cookies.js:105:9
Current stack
applySafeWithoutClone@resource://gre/modules/ExtensionCommon.jsm:306:133
wrapPromise/</<@resource://gre/modules/ExtensionCommon.jsm:517:15
withLastError@resource://gre/modules/ExtensionCommon.jsm:441:14
wrapPromise/<@resource://gre/modules/ExtensionCommon.jsm:509:11
]]

 

Yesterday, I upgraded my kernel. The version I had was not maintained so I compile gentoo-sources-4.9.99. It solved the configuration resetting in Clementine and the sound issue in Firefox. Though, I still have the sort-of locale issue as described.

These outputs doesn't seems to be relevant…

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×