Jump to content
funtoo forums
  • 0
Sign in to follow this  
xsilentmurmurx

LightDM will not start XFCE

Question

Hello all

 I emerged xorg-x11 and xfce4-meta and they installed just fine, I also emerged lightdm and configured my /etc/conf.d/xdm to use DISPLAYMANAGER="lightdm"

but whenever I reboot my system, and LightDM comes up, I put in my username and password and instead of the XFCE desktop starting, LightDM starts up again and I have to relogin and this continues on and on and on.. How do I get xfce4 to start up ? 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0
13 hours ago, cardinal said:

Look for significant errors in ~/.xsession of the account your trying to log into.

 

Thank you for your reply.  I saw the following error in the ~/.xsession-errors  file:

/etc/X11/Sessions/Xsession: line 106: exec: xsm: not found

I emerged xsm and now when I try to login using LightDM, I get a blank black screen. I dont get the XFCE desktop at all. 

Share this post


Link to post
Share on other sites
  • 0
epro show

Do you have mix-ins: xfce

If not

# epro mix-in +xfce
Verify its set:
# epro show
# emerge -avuDN @world

Emerge  xsm:

emerge -av xsm

Check /var/log/lightdm/lightdm.log for more hints if login still fails.

Share this post


Link to post
Share on other sites
  • 0
3 hours ago, cardinal said:

epro show

Do you have mix-ins: xfce

If not


# epro mix-in +xfce
Verify its set:
# epro show
# emerge -avuDN @world

Emerge  xsm:


emerge -av xsm

Check /var/log/lightdm/lightdm.log for more hints if login still fails.

Yes I have the mix-ins for xfce and I ran emerge -avuDN @world and afterwards I reemerged xsm and I rebooted and logged in again, and still I do not see the XFCE desktop.   

 

Here is a link to my /var/log/lightdm/lightdm.log : 

https://paste.pound-python.org/show/aluHLGolO1K9e9worl91/

Share this post


Link to post
Share on other sites
  • 0

Your log says "Greeter requests session Xsession".  It should say "Greeter requests session xfce".   If you have the session type indicator on your greeter screen then be sure that you have xfce selected.  If not then you probably need to adjust your lightdm settings to enable the session indicator or set the default session to xfce.

Share this post


Link to post
Share on other sites
  • 0
17 hours ago, nrc said:

Your log says "Greeter requests session Xsession".  It should say "Greeter requests session xfce".   If you have the session type indicator on your greeter screen then be sure that you have xfce selected.  If not then you probably need to adjust your lightdm settings to enable the session indicator or set the default session to xfce.

 

I tried that, and the XFCE desktop still does not start up...   Here is my /etc/lightdm/lightdm.conf:

https://paste.pound-python.org/show/PRPtuM1TZEGXtzin0i33/

I added user-session=xfce4-session.  I do not know if its even correct lol   but the only thing that happens is a very very minimal xwm session starts but not the XFCE4 session

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×