Jump to content
  • 0
mf2

Gnome keeps pulling in systemd

Question

I've got one machine where I can't install Gnome, since it keeps pulling in systemd beside having the gnome mix-in enabled:

$ epro

=== Enabled Profiles: ===

        arch: x86-64bit
       build: current
     subarch: native_64
      flavor: desktop
     mix-ins: gnome

When I run "emerge -p gnome-light", I a lot of blocking packages:

[blocks B      ] sys-apps/sysvinit ("sys-apps/sysvinit" is blocking sys-apps/systemd-236-r5)
[blocks B      ] >=sys-apps/systemd-197 (">=sys-apps/systemd-197" is blocking sys-auth/nss-myhostname-0.3)
[blocks B      ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/eudev-3.2.2-r1)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking app-admin/openrc-settingsd-1.0.1)
[blocks B      ] sys-auth/nss-myhostname ("sys-auth/nss-myhostname" is blocking sys-apps/systemd-236-r5)
[blocks B      ] sys-fs/eudev ("sys-fs/eudev" is blocking sys-apps/gentoo-systemd-integration-7, sys-apps/systemd-236-r5)
[blocks B      ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/eudev-3.2.2-r1)

Since this worked on other machines, there must the something wrong with my setup. Is it maybe because I've installed gcc 7.2.0?

Full output: https://paste.pound-python.org/show/vWzj7HjakjBEolJHWisp/

emerge --info: https://paste.pound-python.org/show/cHtd5yZI2jFVUEssFYjp/

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...