Jump to content
funtoo forums
  • 0
Sign in to follow this  
xsilentmurmurx

xfce-base/libxfce4util-4.13.1 fails to emerge

Question

hello everyone


I am trying to emerge KDE Plasma 5 and everything is emerging fine, but when I get to xfce-base/libxfce4util-4.13.1,  the emerging fails.  I tried to emerge it separately and it still fails.  

 

here is the build.log for xfce-base/libxfce4util-4.13.1:

https://paste.pound-python.org/show/ozz1CuzVsUsOwFi25PKE/
 

Please let me know if there is anything info I need to provide

 


Thanks!

 

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0
Quote
  1. [31;01m*[0m --------------------------- ACCESS VIOLATION SUMMARY ---------------------------
  2. [31;01m*[0m LOG FILE: "/tmp/sandbox-20774.log"
  3. [31;01m*[0m
  4. VERSION 1.0
  5. FORMAT: F - Function called
  6. FORMAT: S - Access Status
  7. FORMAT: P - Path as passed to function
  8. FORMAT: A - Absolute Path (not canonical)
  9. FORMAT: R - Canonical Path
  10. FORMAT: C - Command Line
  11.  
  12. F: mkdir
  13. S: deny
  14. P: /home/majid/.cache/g-ir-scanner
  15. A: /home/majid/.cache/g-ir-scanner
  16. R: /home/majid/.cache/g-ir-scanner
  17. C: /usr/bin/python2.7 /usr/bin/g-ir-scanner --add-include-path=. --warn-all --identifier-prefix=xfce --identifier-prefix=Xfce --identifier-prefix=libxfce --namespace=libxfce4util --nsversion=1.0 --libtool=/bin/sh ../libtool --include=GObject-2.0 --include=GLib-2.0 --pkg-export=libxfce4util-1.0 --library=libxfce4util.la --cflags-begin -I.. -DDEFAULT_XDG_CACHE_HOME="~/.cache" -DDEFAULT_XDG_DATA_HOME="~/.local/share" -DDEFAULT_XDG_CONFIG_HOME="~/.config" -DDEFAULT_XDG_DATA_DIRS="/usr/share:/usr/local/share:/usr/share" -DDEFAULT_XDG_CONFIG_DIRS="/etc/xdg:/etc/xfce4:/etc/xdg" -DDATADIR="/usr/share" -DSYSCONFDIR="/etc" -DPACKAGE_LOCALE_DIR="/usr/share/locale" -DG_LOG_DOMAIN="libxfce4util" -DKIOSKDIR="/etc/xdg/xfce4/kiosk" -DKIOSKDEF="ALL" -DLIBXFCE4UTIL_COMPILATION --cflags-end xfce-debug.h xfce-fileutils.h xfce-generics.h xfce-i18n.h xfce-kiosk.h xfce-license.h xfce-miscutils.h xfce-posix-signal-handler.h xfce-rc.h xfce-resource.h xfce-utf8.h libxfce4util.h libxfce4util-config.h libxfce4util-alias.h libxfce4util-aliasdef.c libxfce4util-config.c libxfce4util-private.c xfce-fileutils.c xfce-i18n.c xfce-kiosk.c xfce-license.c xfce-miscutils.c xfce-posix-signal-handler.c xfce-rc.c xfce-rc-config.c xfce-rc-simple.c xfce-resource.c xfce-utf8.c libxfce4util.la Makefile --output libxfce4util-1.0.gir
  18. [31;01m*[0m --------------------------------------------------------------------------------

It seems your emerge fails while trying to create the directory /home/majid/.cache/g-ir-scanner. Not sure why. I just installed it on my system without problem. The only thing that seems to be different is the USE flag introspection. It seems to me that you installed it with "+introspection" while my installation was with ""-introspection".

If you don't really need the "support for GObject based introspection" for this package I would suggest trying to install it with "-introspection" and see how it goes.

Share this post


Link to post
Share on other sites
  • 0
38 minutes ago, jhan said:

It seems your emerge fails while trying to create the directory /home/majid/.cache/g-ir-scanner. Not sure why. I just installed it on my system without problem. The only thing that seems to be different is the USE flag introspection. It seems to me that you installed it with "+introspection" while my installation was with ""-introspection".

If you don't really need the "support for GObject based introspection" for this package I would suggest trying to install it with "-introspection" and see how it goes.

Thank you for the reply

 

Emerging it with USE="-introspection" worked, but the problem is when I run this command to update the system and emerge KDE Plasma 5:

 

emerge -auvDN --with-bdeps=y @world kde-plasma/plasma-meta

 

it forces libxfce4util to emerge with USE="+introspection" . Any idea on how I can fix this?

 

Thanks!

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Oleg Vinichenko said:

this failure could happen if your XDG environment incorrectly set. Thats when you start compilation in GUI (terminal emulator), some XDG* variables have special values. TO check, run following in terminal you used:

declare -p ${!XDG*}

thank you for the response Oleg

 

Here you go:

 

# declare -p ${!XDG*}
declare -x XDG_CACHE_HOME="/home/majid/.cache"
declare -x XDG_CONFIG_DIRS="/etc/xdg"
declare -x XDG_CONFIG_HOME="/home/majid/.config"
declare -x XDG_CURRENT_DESKTOP="LXQt"
declare -x XDG_DATA_DIRS="/usr/local/share:/usr/share"
declare -x XDG_DATA_HOME="/home/majid/.local/share"
declare -x XDG_GREETER_DATA_DIR="/var/lib/lightdm-data/majid"
declare -x XDG_MENU_PREFIX="lxqt-"
declare -x XDG_SEAT="seat0"
declare -x XDG_SEAT_PATH="/org/freedesktop/DisplayManager/Seat0"
declare -x XDG_SESSION_COOKIE="funtoohost-1515048768.293209-672040983"
declare -x XDG_SESSION_DESKTOP="lxqt"
declare -x XDG_SESSION_PATH="/org/freedesktop/DisplayManager/Session1"
declare -x XDG_SESSION_TYPE="x11"
declare -x XDG_VTNR="7"

 

Share this post


Link to post
Share on other sites
  • 0
8 minutes ago, palica said:

try

 

su -

 

should set also environment variables

You never fail me Palica :)  That worked!! Thank you! I am now emerging KDE Plasma 5. .Hopefully I wont run into any more issues.   Do you recommend that when I emerge packages, I use su - first to switch into the root user and load all of the root user's environment variables?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×