Jump to content
funtoo forums
  • 0
tsymiroro

keymap in terminal under Xorg (gnome)

Question

Hello

Not new in Funtoo but I forgot how to have my FR keymap in the terminal under Xorg (gnome).

I'm in a fresh install with a new laptop (Lenovo Thinkpad Yoga 13'').

(OutOfTopic : The touchscreen, and the tablet-mode are OK out of the box with Gnome)

The goal is to use "FR/Azerty" keymap

Modified files but not give satisfaction

/etc/conf.d/keymaps

/etc/env.d/02locale

/etc/X11/xorg.conf.d/11-keymap.conf

/etc/locale.gen

/etc/portage/make.conf

In the terminal, when reboot in text mode (rc-update del xdm), the keymap FR is OK

When activating graphic mode in boot (rc-update add xdm default), login screen (lightdm) is in FR, and applications in graphic are in FR (eg. firefox, gedit).

But when I open a terminal (gnome-terminal), keymap is in US/UK (qwerty), when I do setxkbmap fr, it's OK.

The question is, how to make it permanent?

02locale

11-keymap.conf

keymaps

locale.gen

make.conf

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

https://www.funtoo.org/Funtoo_Linux_Localization

talk about Azerty keymap...

only thing I could find for Xorg is gentoo fourms this:

To change the keymap on your console you should change the keymap var in your /etc/conf.d/keymaps:

Code:
keymap="fr"

To change it in X, you can add the setting in your xorg.conf in the keyboard section:

 

Section "InputClass"
        Identifier             "keyboard-layout"
        MatchIsKeyboard        "on"
        Option "XkbLayout"     "fr"
        ...
EndSection

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...