Jump to content
  • 0

Help with install cinnamon


shaman
 Share

Question

Hi,

 

I'm a new user to funtoo and was very amazed on how easy it is to configure and setup(Due to my sleepness nights of my first gentoo install) . Funtoo has rekindled my love for portage again :). I had this setup in no time now I want to try the cinnamon desktop. Would like to know if anyone has installed and how does it run. I know i had some problems on my gentoo machine and went back to slackware version of cinnamon(thanks to willysr). So I'm giving 2.2 a try since slackware only have 3.8 gtk3 version and 2.2 requires 3.10.

 

Thanks

Link to comment
Share on other sites

21 answers to this question

Recommended Posts

  • 0

I'm not sure if cinnamon works on funtoo or not.  I know that there is a mix-in for mate.  It's number 16 on my system.

# eselect profile list
Currently available arch profiles:
  [1]   funtoo/1.0/linux-gnu/arch/x86-64bit * 
  [2]   funtoo/1.0/linux-gnu/arch/pure64
Currently available build profiles:
  [3]   funtoo/1.0/linux-gnu/build/stable
  [4]   funtoo/1.0/linux-gnu/build/current * 
  [5]   funtoo/1.0/linux-gnu/build/experimental
Currently available flavor profiles:
  [6]   funtoo/1.0/linux-gnu/flavor/minimal
  [7]   funtoo/1.0/linux-gnu/flavor/core
  [8]   funtoo/1.0/linux-gnu/flavor/desktop * 
  [9]   funtoo/1.0/linux-gnu/flavor/workstation
  [10]  funtoo/1.0/linux-gnu/flavor/hardened
Currently available mix-ins profiles:
  [11]  funtoo/1.0/linux-gnu/mix-ins/audio (auto) 
  [12]  funtoo/1.0/linux-gnu/mix-ins/console-extras (auto) 
  [13]  funtoo/1.0/linux-gnu/mix-ins/dvd (auto) 
  [14]  funtoo/1.0/linux-gnu/mix-ins/gnome * 
  [15]  funtoo/1.0/linux-gnu/mix-ins/kde
  [16]  funtoo/1.0/linux-gnu/mix-ins/mate
  [17]  funtoo/1.0/linux-gnu/mix-ins/media (auto) 
  [18]  funtoo/1.0/linux-gnu/mix-ins/print (auto) 
  [19]  funtoo/1.0/linux-gnu/mix-ins/python3-only
  [20]  funtoo/1.0/linux-gnu/mix-ins/rhel5-compat
  [21]  funtoo/1.0/linux-gnu/mix-ins/server-db
  [22]  funtoo/1.0/linux-gnu/mix-ins/server-mail
  [23]  funtoo/1.0/linux-gnu/mix-ins/server-web
  [24]  funtoo/1.0/linux-gnu/mix-ins/X (auto) 
  [25]  funtoo/1.0/linux-gnu/mix-ins/xfce
  [26]  funtoo/1.0/linux-gnu/mix-ins/vmware-guest
  [27]  funtoo/1.0/linux-gnu/mix-ins/hardened
Link to comment
Share on other sites

  • 0

The problem is caused by the merge script that generates the funtoo tree, spidermonkey is forked in the funtoo-gnome-overlay[1], and the versions in that overlay override any version that comes from gentoo's tree spidermonkey, I tried to 'emerge -1avp gnome-extra/cjs' on my funtoo and gentoo box, and the gentoo tree does have 'dev-lang/spidermonkey-1.8.5:0/mozjs185', this is the output on funtoo:

$ sudo emerge -pav1 gnome-extra/cjs
These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-lang/spidermonkey-1.8.5:0".
(dependency required by "gnome-extra/cjs-2.2.1" [ebuild])
(dependency required by "gnome-extra/cjs" [argument])

A quick fix would be to get that ebuild from gentoo[2](with the files directory too, patches needed are in there) and put it in your local portage, regenerate the manifest and try to emerge cinnamon again, or wait.

Btw, post the output of emerge, it helps identifying faster what's going on (better than paragraphs of prose) once you have seen it some times.

 

EDIT: this has been fixed by dantrell and you just need to update your tree to get the fixes, in a few hours at maximum.

[1]https://github.com/funtoo/funtoo-gnome-overlay/tree/master/dev-lang/spidermonkey
[2]http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-lang/spidermonkey/

Link to comment
Share on other sites

  • 0

The problem is caused by the merge script that generates the funtoo tree, spidermonkey is forked in the funtoo-gnome-overlay[1], and the versions in that overlay override any version that comes from gentoo's tree spidermonkey, I tried to 'emerge -1avp gnome-extra/cjs' on my funtoo and gentoo box, and the gentoo tree does have 'dev-lang/spidermonkey-1.8.5:0/mozjs185', this is the output on funtoo:

$ sudo emerge -pav1 gnome-extra/cjs
These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy ">=dev-lang/spidermonkey-1.8.5:0".
(dependency required by "gnome-extra/cjs-2.2.1" [ebuild])
(dependency required by "gnome-extra/cjs" [argument])

A quick fix would be to get that ebuild from gentoo[2](with the files directory too, patches needed are in there) and put it in your local portage, regenerate the manifest and try to emerge cinnamon again, or wait.

 

Btw, post the output of emerge, it helps identifying faster what's going on (better than paragraphs of prose) once you have seen it some times.

 

EDIT: this has been fixed by dantrell and you just need to update your tree to get the fixes, in a few hours at maximum.

 

[1]https://github.com/funtoo/funtoo-gnome-overlay/tree/master/dev-lang/spidermonkey

[2]http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/dev-lang/spidermonkey/

What tools are good to use to post terminal output without X to be use for logging info? etc..

Link to comment
Share on other sites

  • 0

If you are not able to run X or connect from a machine (ssh) with X,  you can use app-misc/tmux in copy-mode and extract relevant info to save a file you can latter attach/copy, also there's app-text/pastebin or wget-paste  to paste logs to pastebin sites directly from the CLI.

Link to comment
Share on other sites

  • 0

Finally got cinnamon running like linux mint. Had to add dbus to runlevel default. Make sure to eselect you gpu driver for opengl as this is not done automatic. Enable the introspection,dbus,and networkmanager flag. Install upower-pm-utils to prevent systemd upower install.

Link to comment
Share on other sites

  • 0

http://www.ubuntuupdates.org/package/mint_main/qiana/main/base/mint-backgrounds-qiana

 

I extracted this .deb to get linux mint wallpapers. Which look nice by the way. Cinnamon-Settings is not changing the desktop background so, just right click the image in the file manager. Apparently this effects all non-linuxmint distros.

Link to comment
Share on other sites

  • 0

http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/sys-power/upower-pm-utils/ChangeLog?revision=1.1&view=markup

Had to emerge upower-pm-utils to get around the upower systemd conflict. Also I change my mix-ins profile to gnome as I figure I will probably need that will wait and see after merge what I get...

 

Can you explain more about this conflict? What package wanted upower-pm-utils?

Link to comment
Share on other sites

  • 0

 

shaman@Ceres ~ $ equery d upower-pm-utils

 * These packages depend on upower-pm-utils:

gnome-extra/cinnamon-2.2.14 (sys-power/upower-pm-utils[introspection])

gnome-extra/cinnamon-control-center-2.2.10 (sys-power/upower-pm-utils)

gnome-extra/cinnamon-session-2.2.2 (!systemd ? sys-power/upower-pm-utils)

gnome-extra/cinnamon-settings-daemon-2.2.4 (sys-power/upower-pm-utils)

net-misc/networkmanager-0.9.8.2-r2 (sys-power/upower-pm-utils)

 

equery d upower

 * These packages depend on upower:

gnome-extra/cinnamon-2.2.14 (sys-power/upower[introspection])

gnome-extra/cinnamon-control-center-2.2.10 (>=sys-power/upower-0.9.1)

gnome-extra/cinnamon-session-2.2.2 (!systemd ? <sys-power/upower-0.99)

gnome-extra/cinnamon-settings-daemon-2.2.4 (>=sys-power/upower-0.9.11)

net-misc/networkmanager-0.9.8.2-r2 (sys-power/upower)

 

 

 

 

                                shaman@Ceres ~ $ equery d systemd

 * These packages depend on systemd:

app-admin/openrc-settingsd-1.0.1 (systemd ? >=sys-apps/systemd-197)

gnome-base/gvfs-1.20.2 (systemd ? sys-apps/systemd:0)

gnome-extra/cinnamon-control-center-2.2.10 (>=sys-apps/systemd-31)

gnome-extra/cinnamon-screensaver-2.2.4 (systemd ? >=sys-apps/systemd-31:0)

gnome-extra/cinnamon-session-2.2.2 (systemd ? >=sys-apps/systemd-183)

gnome-extra/cinnamon-settings-daemon-2.2.4 (systemd ? sys-apps/systemd:0)

media-sound/pulseaudio-5.0-r2 (systemd ? sys-apps/systemd:0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?])

net-misc/networkmanager-0.9.8.2-r2 (systemd ? >=sys-apps/systemd-200)

                                   (>=sys-apps/systemd-183)

sys-apps/accountsservice-0.6.37 (systemd ? >=sys-apps/systemd-186:0)

sys-apps/dbus-1.8.6 (systemd ? sys-apps/systemd:0)

sys-auth/pambase-20140313 (systemd ? >=sys-apps/systemd-204[pam])

sys-auth/polkit-0.112-r2 (systemd ? sys-apps/systemd:0)

sys-process/procps-3.3.9-r1 (systemd ? >=sys-apps/systemd-209)

virtual/service-manager-0 (kernel_linux ? sys-apps/systemd)

x11-base/xorg-server-1.16.0 (systemd ? sys-apps/systemd)

x11-misc/colord-1.2.1-r1 (systemd ? >=sys-apps/systemd-44:0)

 

 

The only way I got out of this was masked systemd and upower. But I installed upower-pm-utils first. Cinnamon refused to installed as the fore mention was in conflict with each other all of them wanted to be installed at the same time.

Link to comment
Share on other sites

  • 0

Thanks, that explains things a little. The focus has been on GNOME 3.12 and other DEs. It would be a good idea to check to see how our upower changes are impacting things (at the very least, I now know it's causing issues with cinnamon) so I will look into this as time permits.

Link to comment
Share on other sites

  • 0

Thanks, that explains things a little. The focus has been on GNOME 3.12 and other DEs. It would be a good idea to check to see how our upower changes are impacting things (at the very least, I now know it's causing issues with cinnamon) so I will look into this as time permits.

Thanks, I look forward to the improvement in this and a cinnamon mix profile is a excellent idea. As Mate and Cinnamon confines to carry on the similarities of gnome 2 with it's simple functionality. 

Link to comment
Share on other sites

  • 0

Using cinnamon desktop with tracker miner fs crashes while desktop is going to sleep. Removing the -miner-fs flag which is optional seems to fix my issue so far.

That didn't help. Keep getting crashing "tracker-miner-fs 16677 cinnamon GLib-GIO-CRITICAL **: Error while sending AddMatch()"

I will open a bug on this.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...