Jump to content
funtoo forums
  • 0
hick518

xorg conflicts

Question

After following the instructions at https://github.com/funtoo/meta-repoI attempted to 'emerge -auDN @world'.  It's not going well.  I'm getting the following message. 

Oops! Conflicts have been encountered:

>>> x11-drivers/xf86-input-synaptics-1.8.3:0/0::gentoo, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-video-vesa-2.3.4:0/0::gentoo, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-input-mouse-1.9.1:0/0::gentoo, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-video-nouveau-1.0.12:0/0::gentoo, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-input-keyboard-1.8.1:0/0::gentoo, installed, wants x11-base/xorg-server:0/1.18.4=

My candidates are:

>>> x11-base/xorg-server-1.17.4-r2:0/1.17.4::xorg-kit, ebuild scheduled for merge has SLOT 0/1.17.4
>>> x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed has SLOT 0/1.18.4
>>> x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed, wants >=x11-base/xorg-drivers-1.18

My candidates are:

>>> x11-base/xorg-drivers-1.17:0/0::xorg-kit, ebuild scheduled for merge has SLOT 0/0
>>> x11-base/xorg-drivers-1.18-r1:0/0::gentoo, installed has SLOT 0/0


We hope this informational output has been useful in identifying the
problem. We are continually working to reduce conflicts. Do not
hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)

I'm still a little unclear how kits are supposed to work, so it's possible I've done something wrong.  I was running Funtoo stable, and I'd like to minimize my daily updates.  So /etc/ego.conf does not have any kits defined.
 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

These new error messages still have me confused. Can't make out what the program is trying to tell me.

 

But as far as I remember, after switching to kits some of the X11 packages got downgraded. It seems to me that you have the newer versions (1.18.4) installed. The first five packages should then have been compiled against this version and thus want the newer version, which is not in the tree.

 

What do you get when you try:

emerge xorg-server xf86-input-synaptics xf86-video-vesa xf86-input-mouse xf86-video-nouveau xf86-input-keyboard

Share this post


Link to post
Share on other sites
  • 0

emerge -av xorg-server xf86-input-synaptics xf86-video-vesa xf86-input-mouse xf86-video-nouveau xf86-input-keyboard

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] x11-base/xorg-server-1.17.4-r2:0/1.17.4::xorg-kit [1.18.4:0/1.18.4::gentoo] USE="ipv6 kdrive nptl%* suid udev xephyr xnest xorg -dmx -doc -glamor (-libressl) -minimal (-selinux) -static-libs (-systemd) -tslib -unwind -wayland -xvfb" 5,656 KiB
[ebuild   R    ] x11-drivers/xf86-input-synaptics-1.8.3::xorg-kit [1.8.3::gentoo] 473 KiB
[ebuild   R    ] x11-drivers/xf86-video-vesa-2.3.4::xorg-kit [2.3.4::gentoo] 279 KiB
[ebuild   R    ] x11-drivers/xf86-input-mouse-1.9.1::xorg-kit [1.9.1::gentoo] 341 KiB
[ebuild   R    ] x11-drivers/xf86-video-nouveau-1.0.12::xorg-kit [1.0.12::gentoo] 586 KiB
[ebuild   R    ] x11-drivers/xf86-input-keyboard-1.8.1::xorg-kit [1.8.1::gentoo] 312 KiB
[blocks B      ] >=x11-drivers/xf86-input-evdev-2.10 (">=x11-drivers/xf86-input-evdev-2.10" is blocking x11-base/xorg-server-1.17.4-r2)

Total: 6 packages (1 downgrade, 5 reinstalls), Size of downloads: 7,645 KiB
Conflict: 1 block (1 unsatisfied)

Oops! Conflicts have been encountered:

>>> x11-base/xorg-server, wants xorg-server
>>> x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, installed, wants >=x11-base/xorg-server-1.18[udev]
>>> x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-video-vmware-13.1.0:0/0::gentoo, installed, wants x11-base/xorg-server:0/1.18.4=

My candidates are:

>>> x11-base/xorg-server-1.17.4-r2:0/1.17.4::xorg-kit, ebuild scheduled for merge has SLOT 0/1.17.4
>>> x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed has SLOT 0/1.18.4


We hope this informational output has been useful in identifying the
problem. We are continually working to reduce conflicts. Do not
hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  x11-drivers/xf86-input-evdev-2.10.3:0/0::gentoo, installed pulled in by
    x11-drivers/xf86-input-evdev required by x11-base/xorg-drivers-1.18-r1:0/0::gentoo, installed


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

Share this post


Link to post
Share on other sites
  • 0

OK, progress. It seems that you'll need to add xf86-input-evdev to that line as well:

emerge xorg-server xf86-input-synaptics xf86-video-vesa xf86-input-mouse xf86-video-nouveau xf86-input-keyboard xf86-input-evdev

Be prepared that there could be more blocked packages. I found it often helpful to add them to the emerge command line then.

Share this post


Link to post
Share on other sites
  • 0

Actually, I was able to upgrade @world by excluding only xf86-input-evdev.  So I am fully updated except for some xorg-related stuff.  Any ideas what I should do to update those?  Am I going to have to unmerge them all, then emerge them again?  (And hope that nothing goes wrong?)

 

# emerge -auDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] x11-base/xorg-drivers-1.17 [1.18-r1]
[ebuild     UD ] x11-base/xorg-server-1.17.4-r2 [1.18.4] USE="nptl%*"
[ebuild     UD ] x11-drivers/xf86-input-evdev-2.9.2 [2.10.3]
[blocks b      ] >=x11-drivers/xf86-input-evdev-2.10 (">=x11-drivers/xf86-input-evdev-2.10" is blocking x11-base/xorg-server-1.17.4-r2)

Oops! Conflicts have been encountered:

>>> x11-drivers/xf86-video-nouveau-1.0.12:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-video-vesa-2.3.4:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-input-synaptics-1.8.3:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-input-keyboard-1.8.1:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-input-mouse-1.9.1:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-video-vmware-13.1.0:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=

My candidates are:

>>> x11-base/xorg-server-1.17.4-r2:0/1.17.4::xorg-kit, ebuild scheduled for merge has SLOT 0/1.17.4
>>> x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed has SLOT 0/1.18.4
>>> x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed, wants >=x11-base/xorg-drivers-1.18

My candidates are:

>>> x11-base/xorg-drivers-1.17:0/0::xorg-kit, ebuild scheduled for merge has SLOT 0/0
>>> x11-base/xorg-drivers-1.18-r1:0/0::gentoo, installed has SLOT 0/0


We hope this informational output has been useful in identifying the
problem. We are continually working to reduce conflicts. Do not
hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)

Share this post


Link to post
Share on other sites
  • 0

 

Actually, I was able to upgrade @world by excluding only xf86-input-evdev.  So I am fully updated except for some xorg-related stuff.  Any ideas what I should do to update those?  Am I going to have to unmerge them all, then emerge them again?  (And hope that nothing goes wrong?)

 

# emerge -auDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] x11-base/xorg-drivers-1.17 [1.18-r1]
[ebuild     UD ] x11-base/xorg-server-1.17.4-r2 [1.18.4] USE="nptl%*"
[ebuild     UD ] x11-drivers/xf86-input-evdev-2.9.2 [2.10.3]
[blocks b      ] >=x11-drivers/xf86-input-evdev-2.10 (">=x11-drivers/xf86-input-evdev-2.10" is blocking x11-base/xorg-server-1.17.4-r2)

Oops! Conflicts have been encountered:

>>> x11-drivers/xf86-video-nouveau-1.0.12:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-video-vesa-2.3.4:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-input-synaptics-1.8.3:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-input-keyboard-1.8.1:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-input-mouse-1.9.1:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=
>>> x11-drivers/xf86-video-vmware-13.1.0:0/0::xorg-kit, installed, wants x11-base/xorg-server:0/1.18.4=

My candidates are:

>>> x11-base/xorg-server-1.17.4-r2:0/1.17.4::xorg-kit, ebuild scheduled for merge has SLOT 0/1.17.4
>>> x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed has SLOT 0/1.18.4
>>> x11-base/xorg-server-1.18.4:0/1.18.4::gentoo, installed, wants >=x11-base/xorg-drivers-1.18

My candidates are:

>>> x11-base/xorg-drivers-1.17:0/0::xorg-kit, ebuild scheduled for merge has SLOT 0/0
>>> x11-base/xorg-drivers-1.18-r1:0/0::gentoo, installed has SLOT 0/0


We hope this informational output has been useful in identifying the
problem. We are continually working to reduce conflicts. Do not
hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)

mv /var/lib/portage/world /var/lib/portage/world.bak and try updating.

 

Share this post


Link to post
Share on other sites
  • 0

I would first see if

emerge xorg-drivers xorg-server xf86-input-evdev

work. If this still doesn't work I would unmerge xf86-input-evdev and try again.

 

This worked, thanks.  And a subsequent 'emerge -auDN @world' worked as well, with no errors.

 

I've seen this before -- sometimes packages fail to upgrade during 'emerge -auDN @world', but the same packages can be upgraded via 'emerge packagename'.  Can anybody tell me why?

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×