Jump to content
funtoo forums
mauricev

python woes

Recommended Posts

After updating to the new scheme of syncing the portage tree, I'm having trouble with getting anything that requires python to emerge.

 

For example, I get this

!!! The ebuild selected to satisfy "sys-boot/boot-update" has unmet requirements.
- sys-boot/boot-update-1.8.2::core-kit USE="" PYTHON_SINGLE_TARGET="-python3_4 -python3_5 -python3_6" PYTHON_TARGETS="-python3_4 -python3_5 -python3_6"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( python_single_target_python3_4 python_single_target_python3_5 python_single_target_python3_6 )

  The above constraints are a subset of the following complete expression:
    exactly-one-of ( python_single_target_python3_4 python_single_target_python3_5 python_single_target_python3_6 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 ) python_single_target_python3_6? ( python_targets_python3_6 )

despite the fact I have this in /etc/portage/make.conf

PYTHON_TARGETS="python2_7 python3_6"
PYTHON_SINGLE_TARGET="python3_6"

It requires me to manually supply in package.use

sys-boot/boot-update python_single_target_python3_4 python_targets_python3_4

and it has to be 3.4. 3.6 won't work.

 

Then I get this

emerge: there are no ebuilds to satisfy "dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".

Despite the fact it's already emerged

[ebuild   R    ] dev-python/setuptools-36.4.0::python-kit  USE="{-test}" PYTHON_TARGETS="python2_7 -pypy -pypy3 -python3_4 (-python3_5) (-python3_6)" 0 KiB

Share this post


Link to post
Share on other sites

did you update ego yet? should be 2.0.9 I think..

try

emerge -1 app-admin/ego

then you can use:

ego sync

to synchronize the portage tree

 

may be that then you need to update your portage

but updating ego worked for me.

Share this post


Link to post
Share on other sites

did you update ego yet? should be 2.0.9 I think..

try

emerge -1 app-admin/ego

then you can use:

ego sync

to synchronize the portage tree

 

may be that then you need to update your portage

but updating ego worked for me.

This results in the same error.

vm meta-repo # sudo emerge -1 -v app-admin/ego

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-python/setuptools[python_targets_pypy(-)?,python_targets_pypy3(-)?,python_targets_python2_7(-)?,python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_pypy(-),-python_single_target_pypy3(-),-python_single_target_python2_7(-),-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".
(dependency required by "dev-python/chardet-3.0.4::python-kit" [ebuild])
(dependency required by "dev-python/requests-2.12.5::python-kit" [ebuild])
(dependency required by "app-admin/ego-2.0.9::core-kit" [ebuild])
(dependency required by "app-admin/ego" [argument])

Share this post


Link to post
Share on other sites

What's posted there doesn't help because 

Ego module sync does not exist.

and

epro update
Please specify a valid action.

I also have this problem,

equery l ego
!!! Unable to parse profile: '/etc/portage/make.profile'
!!! ParseError: Parent 'gentoo:funtoo/1.0/linux-gnu/arch/x86-32bit' not found: '/etc/portage/make.profile/parent'
 * Searching for ego ...
[I--] [??] app-admin/ego-1.0.1:0

Share this post


Link to post
Share on other sites

ah yea, that all looks very familiar to me, except for the profile part.

 

there was a news item that said to update ego back in august that i missed , I think it was 1.1.3-r?

that version is no longer in the tree.

 

I think this is how I got past the problem putting in make.conf

PYTHON_SINGLE_TARGET="python3_4"
PYTHON_TARGETS="python2_7 python3_4"
 

thats assuming you have python3_4 still.

then try emerge ego again.

Share this post


Link to post
Share on other sites

when did you last update your tree?

 

# cd /var/git/meta-repo
# git pull
# git submodule init
# git submodule update
# emerge -1 ego

 

I had much the same problem but it didn't take long to workaround.

 

you have eix?

eix app-admin/ego

Share this post


Link to post
Share on other sites

I still get

vm portage # sudo emerge -1 ego
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-python/setuptools[python_targets_python3_4(-)?,python_targets_python3_5(-)?,python_targets_python3_6(-)?,-python_single_target_python3_4(-),-python_single_target_python3_5(-),-python_single_target_python3_6(-)]".
(dependency required by "dev-python/appi-0.1.9999::python-kit" [ebuild])
(dependency required by "app-admin/ego-2.0.9::core-kit" [ebuild])
(dependency required by "ego" [argument])

eix reveals

[U] app-admin/ego
     Available versions:  2.0.9^m **2.0.10^m **2.0.12^m {python_single_target_python3_4 python_single_target_python3_5 python_single_target_python3_6 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6 zsh-completion}
     Installed versions:  1.0.1^m[?](01:06:28 AM 05/11/2017)
     Homepage:            http://www.funtoo.org/Package:Ego
     Description:         Funtoo's configuration tool: ego, epro, edoc.

Share this post


Link to post
Share on other sites

Assuming that you've updated your tree as per above you may need to apply --nodeps to get ego up to a serviceable version.  Then run 'epro update' and 'ego sync'.

Share this post


Link to post
Share on other sites

nrc, you make a valid point I never considered the --nodeps may work as well,. thanks for that!

 

look at your eix result and then look at mine.. 

 

I don't know why they would be different but it might be a problem

 

edit: I looked and perhaps that is perfectly acceptable, .


[I] app-admin/ego
     Available versions:  2.0.9^m **2.0.10^m **2.0.12^m {zsh-completion PYTHON_SINGLE_TARGET="python3_4 python3_5 python3_6" PYTHON_TARGETS="python3_4 python3_5 python3_6"}
     Installed versions:  2.0.9^m(08:20:57 PM 09/13/2017)(-zsh-completion PYTHON_SINGLE_TARGET="python3_4 -python3_5 -python3_6" PYTHON_TARGETS="python3_4 -python3_5 -python3_6")
     Homepage:            http://www.funtoo.org/Package:Ego
     Description:         Funtoo's configuration tool: ego, epro, edoc.

the problem is your python use flags and profile got disconnected from portage with the meta-repo change.

add dev-python/setuptools dev-python/appi app-admin/ego to portage.use with a python target and a python single target.

How you write them PYTHON_TARGETS_PYTHON3_4 or PYTHON_TARGET="python3_4" ? may or may no matter.

I would recommend python3_4 as a single and 3_4 2_7 as python target.

 

then run emerge -1 dev-python/setuptools dev-python/appi app-admin/ego

Share this post


Link to post
Share on other sites

With the following setup

dev-python/setuptools python_targets_python3_6 python_targets_python3_4 python_targets_python2_7 python_single_target_python3_4
dev-python/appi python_targets_python3_4python_targets_python2_7 python_single_target_python3_4
app-admin/ego python_targets_python3_4 python_targets_python2_7 python_single_target_python3_4

I get the same error as above.

 

When I try it without deps, I get

* Messages for package dev-python/appi-0.2.9999:

 * ERROR: dev-python/appi-0.2.9999::python-kit failed (compile phase):
 *   (no error message)
 * 
 * Call stack:
 *     ebuild.sh, line  115:  Called src_compile
 *   environment, line 3153:  Called distutils-r1_src_compile
 *   environment, line  976:  Called _distutils-r1_run_foreach_impl 'distutils-r1_python_compile'
 *   environment, line  280:  Called python_foreach_impl 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 2693:  Called multibuild_foreach_variant '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 1995:  Called _multibuild_run '_python_multibuild_wrapper' 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line 1993:  Called _python_multibuild_wrapper 'distutils-r1_run_phase' 'distutils-r1_python_compile'
 *   environment, line  709:  Called distutils-r1_run_phase 'distutils-r1_python_compile'
 *   environment, line  967:  Called distutils-r1_python_compile
 *   environment, line  842:  Called esetup.py 'build'
 *   environment, line 1221:  Called die
 * The specific snippet of code:
 *       "${@}" || die "${die_args[@]}";
 * 

Share this post


Link to post
Share on other sites

Hi, I think it qualifies as a bug..

 

posting the result of emerge --info and contents of make.conf would go along way in seeing part of whats happening, but

 

posting to bugs.funtoo.org should get more responses.

 

just found this : http://www.funtoo.org/index.php?title=News:Python_Multiplexing(And_another_Ego_update)&diff=19639&oldid=19021

 

but I think you have already tried this?

 

dave

Share this post


Link to post
Share on other sites

I think I resolved this by cheating. My machine is virtual so I reverted to a snapshot before I made any changes then proceeded to start over, starting with the instructions at https://github.com/funtoo/meta-repo. I then added the following:

dev-python/appi python_targets_python3_4
dev-python/mwparserfromhell python_targets_python3_4
dev-python/requests python_targets_python3_4
dev-python/cryptography python_targets_python3_4
dev-python/pyasn1 python_targets_python3_4
dev-python/pyopenssl python_targets_python3_4
dev-python/ply python_targets_python3_4
dev-python/py python_targets_python3_4
dev-python/pycparser python_targets_python3_4
dev-python/idna python_targets_python3_4
dev-python/ndg-httpsclient python_targets_python3_4
dev-python/urllib3 python_targets_python3_4
dev-python/chardet python_targets_python3_4
dev-python/PySocks python_targets_python3_4
dev-python/cffi python_targets_python3_4
virtual/python-ipaddress python_targets_python3_4
app-admin/ego python_single_target_python3_4 python_targets_python3_4 

I still have to re-emerge world to make sure everything is good, but I did manage to get ego installed and it's syncing.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×