Jump to content
funtoo forums
  • 0
Sign in to follow this  
pascalbrax

pkgconf and pkgconfig conflict in emerge -u

Question

I'm not really sure how to proceed about this one, don't want to unmerge and emerge again something critical for my system...

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-arch/lzip-1.19 [1.19_pre1]
[ebuild  N     ] virtual/pkgconfig-0-r1  ABI_X86="32 (64) (-x32)"
[ebuild     UD ] sys-apps/keyutils-1.5.9-r4 [1.5.10]
[ebuild     UD ] dev-python/pyrsistent-0.12.0 [0.12.1]
[ebuild     U  ] app-crypt/acme-0.18.1 [0.18.0]
[ebuild     U  ] app-crypt/certbot-0.18.1 [0.18.0]
[ebuild     U  ] dev-libs/libxml2-2.9.4-r2 [2.9.4-r1] PYTHON_TARGETS="-python3_6%"
[ebuild     UD ] x11-misc/util-macros-1.19.0 [1.19.1]
[ebuild  N     ] dev-util/pkgconfig-0.29.2  USE="-build -hardened" ABI_X86="(64) -32 (-x32)"
[ebuild     UD ] media-tv/plex-media-server-1.3.4-r1 [1.8.4]
[ebuild     U  ] mail-client/mutt-1.9.0 [1.8.3] USE="(-prefix)"
[ebuild     U  ] app-editors/vim-core-8.0.1092 [8.0.1071]
[ebuild     U  ] app-editors/vim-8.0.1092 [8.0.1071]
[ebuild     UD ] dev-python/testtools-2.2.0 [2.3.0]
[blocks B      ] dev-util/pkgconfig ("dev-util/pkgconfig" is blocking dev-util/pkgconf-1.2.2)
[blocks B      ] dev-util/pkgconf[pkg-config] ("dev-util/pkgconf[pkg-config]" is blocking dev-util/pkgconfig-0.29.2)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-util/pkgconfig-0.29.2:0/0::dev-kit, ebuild scheduled for merge) pulled in by
    dev-util/pkgconfig required by (media-video/luvcview-0.2.6:0/0::gentoo, installed)
    >=dev-util/pkgconfig-0.23 required by (x11-apps/mkfontdir-1.0.7:0/0::gentoo, installed)
    >=dev-util/pkgconfig-0.23 required by (media-fonts/encodings-1.0.4:0/0::gentoo, installed)
    >=dev-util/pkgconfig-0.23 required by (media-fonts/font-misc-misc-1.1.2:0/0::gentoo, installed)

  (dev-util/pkgconf-1.2.2:0/0::core-kit, installed) pulled in by
    dev-util/pkgconf[pkg-config,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (dev-util/pkgconf[pkg-config,abi_x86_32(-),abi_x86_64(-)]) required by (virtual/pkgconfig-0-r1:0/0::core-kit, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

BTW after the ego/epro switch, lots of packages are marked to "downgrade" in my portage tree.

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×