Jump to content
funtoo forums
  • 0
Sign in to follow this  
fabiolima

Install rstudio

Question

Hello Guys 

 

I am try rstudio in Funtoo

 

This error when compiler  in 62% not found java compiler have this code:

    [java] Linking into /var/tmp/portage/sci-mathematics/rstudio-1.0.153/work/rstudio-1.0.153/src/gwt/www/rstudio; Writing extras to /var/tmp/portage/sci-mathematics/rstudio-1.0.153/work/rstudio-1.0.153/src/gwt/extras/rstudio
     [java]    Link succeeded
     [java]    Linking succeeded -- 1.367s

build:

BUILD SUCCESSFUL
Total time: 3 minutes 12 seconds
make[2]: Leaving directory '/var/tmp/portage/sci-mathematics/rstudio-1.0.153/work/rstudio-1.0.153_build'
[ 62%] Built target gwt_build
make[1]: Leaving directory '/var/tmp/portage/sci-mathematics/rstudio-1.0.153/work/rstudio-1.0.153_build'
Makefile:151: recipe for target 'all' failed
make: *** [all] Error 2
 * ERROR: sci-mathematics/rstudio-1.0.153::science-kit failed (compile phase):
 *   emake failed
 * 
 * If you need support, post the output of `emerge --info '=sci-mathematics/rstudio-1.0.153::science-kit'`,
 * the complete build log and the output of `emerge -pqv '=sci-mathematics/rstudio-1.0.153::science-kit'`.
 * The complete build log is located at '/var/tmp/portage/sci-mathematics/rstudio-1.0.153/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sci-mathematics/rstudio-1.0.153/temp/environment'.
 * Working directory: '/var/tmp/portage/sci-mathematics/rstudio-1.0.153/work/rstudio-1.0.153_build'
 * S: '/var/tmp/portage/sci-mathematics/rstudio-1.0.153/work/rstudio-1.0.153'
!!! When you file a bug report, please include the following information:
GENTOO_VM=oracle-jdk-bin-1.8  CLASSPATH="" JAVA_HOME="/opt/oracle-jdk-bin-1.8.0.144"
JAVACFLAGS="-source 1.8 -target 1.8" COMPILER=""
and of course, the output of emerge --info =rstudio-1.0.153


Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

  • 0

[ebuild  N     ] sci-mathematics/rstudio-1.1.383::science-kit  USE="-dedicated -server" 207,262 KiB

compiled for me without problems. If you are still experiencing problems let us know. When possible supplying also ebuild.log.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×