Jump to content
funtoo forums
  • 0
Sandro

[Funtoo "Stable"] Updates difficulties.

Question

Hi to All.... this time I'm not able to resolve the dependencies. 

I did some tests enabling and disabling Use flags, but I'm not able to solve :(
 
Could someone kindly help me? 
 
Thank you :)
 
 

ci7ht ~ # emerge --info
Portage 2.3.6-r8 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.8.2, glibc-2.18-r1, 3.15.5-gentoo x86_64)
=================================================================
System uname: Linux-3.15.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-4771_CPU_@_3.50GHz-with-gentoo-2.2.0
KiB Mem:    16373168 total,   9894004 free
KiB Swap:    8388604 total,   8388604 free
Timestamp of tree: Unknown
ld ld di GNU (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.2_p45-r1
dev-java/java-config:     2.2.0-r1000
dev-lang/python:          2.7.8-r1000, 3.3.5-r1000
dev-util/cmake:           2.8.12.2-r1
sys-apps/baselayout:      2.2.0-r6
sys-apps/openrc:          0.12.3-r3
sys-apps/sandbox:         2.6-r2
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.8.2-r2
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.18-r1
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -mfpmath=sse"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe -mfpmath=sse"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-march=native -O2 -pipe -mfpmath=sse"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="it_IT.utf8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,--hash-style=gnu"
LINGUAS="it"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/dev/shm"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X Xaw3d a52 aac aacplus aalib acl acpi alsa amd64 apm apng applet audio avx avx2 bash-completion bcmath berkdb bidi blas bluetooth bluray bzip2 cairo calendar canna caps cdb cdda cddb cdparanoia cdr clamav consolekit cracklib crypt css ctype cue cups custom-cflags custom-cpuopts custom-optimization cvs cxx dbi dbm dbus dga dhcpcd djvu dri dts dv dvb dvd dvdr dvdread eds encode evo exif expat faac fastcgi fat fax ffmpeg fftw flac fltk fluidsynth foomaticdb fortran ftp gd gdbm geoip ggi gif gimp git gles2 glut gmp gnutls gphoto2 gpm gps graphviz gsf gsl gsm gstreamer gtk guile gzip hddtemp hpijs iconv icq icu ieee1394 imap introspection ios ipod iptc ipv6 jack java jpeg jpeg2k kde lame libass libcaca libffi libnotify libsamplerate libv4l lirc lm_sensors lock lzma lzo mad maildir matroska mbox memlimit mercurial midi mikmod mime mmap mms mmx mng modules mp3 mp4 mpeg mpi mpi-threads mplayer msn mudflap multilib musicbrainz mysql ncurses networkmanager nls nokia nptl nsplugin nvidia ogg openal opencl openexr opengl openmp openrc pam pcmcia pcre pda pdf perl pic plasma png policykit ppds pppd pulseaudio python qt3support qt4 quicktime rar raw readline realtime recode resolvconf ruby scanner schroedinger sdl semantic-desktop session shorten sip smartcard smp smpeg soap sound sox speex sql sse sse2 sse3 sse4 sse4_1 ssl ssse3 startup-notification static-libs static-ppds svg szip taglib tcpd theora threads thunar thunderbird tiff timidity tk truetype twolame udev unicode usb v4l v4l2 vaapi vdpau video vlc vorbis vpx wavpack webgl wifi win32codecs wmf wxwidgets x264 xcomposite xface xft xine xinerama xml xmp xpm xps xscreensaver xv xvid xvmc zip zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="it" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK
 

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

 

@sputnik : I was just writing the solution ..... But you came before me to understand the problem :)

 
I had to unmask the latest version (= dev-util/gdbus-codegen-2.40.0-r1000)
 
I am now an update for 152 ebuilds ..... :)
I hope everything goes well :)
 
Thank You Very Much for All.

 

 

I was thinking it was this but I wasn't sure as it should have already been unmasked. Thanks for letting us know and good to hear your world update is on the way. :)

Share this post


Link to post
Share on other sites
  • 0
Hello Sandro.

I don't know if I can help, I did look.  It's seems like something going on with gdbus-codegen and glib eh?  And yet, I have this:



[I] dev-util/gdbus-codegen
      Installed versions:  2.40.0-r1000{tbz2}(08:24:39 PM 06/11/2014)(PYTHON_ABIS="2.7 3.3 -2.6 -3.1 -3.2 -3.4 -3.5")
[I] dev-libs/glib
     Installed versions:  2.40.0-r1(2){tbz2}(05:35:24 PM 06/17/2014)(mime static-libs -debug -fam -selinux -systemtap -test -utils -xattr ABI_MIPS="-n32 -n64 -o32" ABI_X86="32 -64 -x32" KERNEL="linux" PYTHON_TARGETS="python2_7 -python2_6")


A good point by dantrell, but I believe Sandro has unstable.  I do, and he has same versions of core programs.

I wonder if you might fare better by including --exclude gdbus-codegen -- for some reason it's being forced to downgrade?  And even more amazing, listed as a new emerge, yet obviously you have the 2.40xxx version.  Might work, or might not, you can try it and see.  Whenever you have a bunch of downgrades like that, even without blocks, it's a big clue something's not right.

Sometimes you have to --unmerge it temporarily, pkgbuilds are handy for that.  

Often you can take the offender out of the mix, emerge the rest and magically everything is fine.  Hope it goes that way for you, or others can give some better advice.

Share this post


Link to post
Share on other sites
  • 0

@dantrell: Thank You very much :)

 This is myprofile (I have not make downgrades

sandro@ci7ht ~ $ eselect profile list
Currently available arch profiles:
  [1]   funtoo/1.0/linux-gnu/arch/x86-64bit * 
  [2]   funtoo/1.0/linux-gnu/arch/pure64
Currently available build profiles:
  [3]   funtoo/1.0/linux-gnu/build/stable * 
  [4]   funtoo/1.0/linux-gnu/build/current
  [5]   funtoo/1.0/linux-gnu/build/experimental
Currently available flavor profiles:
  [6]   funtoo/1.0/linux-gnu/flavor/minimal
  [7]   funtoo/1.0/linux-gnu/flavor/core
  [8]   funtoo/1.0/linux-gnu/flavor/desktop * 
  [9]   funtoo/1.0/linux-gnu/flavor/workstation
  [10]  funtoo/1.0/linux-gnu/flavor/hardened
Currently available mix-ins profiles:
  [11]  funtoo/1.0/linux-gnu/mix-ins/audio (auto) 
  [12]  funtoo/1.0/linux-gnu/mix-ins/console-extras (auto) 
  [13]  funtoo/1.0/linux-gnu/mix-ins/dvd (auto) 
  [14]  funtoo/1.0/linux-gnu/mix-ins/gnome
  [15]  funtoo/1.0/linux-gnu/mix-ins/kde * 
  [16]  funtoo/1.0/linux-gnu/mix-ins/mate
  [17]  funtoo/1.0/linux-gnu/mix-ins/media (auto) 
  [18]  funtoo/1.0/linux-gnu/mix-ins/print (auto) 
  [19]  funtoo/1.0/linux-gnu/mix-ins/python3-only
  [20]  funtoo/1.0/linux-gnu/mix-ins/rhel5-compat
  [21]  funtoo/1.0/linux-gnu/mix-ins/server-db
  [22]  funtoo/1.0/linux-gnu/mix-ins/server-mail
  [23]  funtoo/1.0/linux-gnu/mix-ins/server-web
  [24]  funtoo/1.0/linux-gnu/mix-ins/X (auto) 
  [25]  funtoo/1.0/linux-gnu/mix-ins/xfce * 
  [26]  funtoo/1.0/linux-gnu/mix-ins/vmware-guest
  [27]  funtoo/1.0/linux-gnu/mix-ins/hardened

Share this post


Link to post
Share on other sites
  • 0

@sputnik : I was just writing the solution ..... But you came before me to understand the problem :)

 
I had to unmask the latest version (= dev-util/gdbus-codegen-2.40.0-r1000)
 
I am now an update for 152 ebuilds ..... :) 
I hope everything goes well :)
 
Thank You Very Much for All.

Share this post


Link to post
Share on other sites
  • 0

Ok .... about updates: all ok except media-libs/mlt; then for this moment I've uninstalled kdenlive (that requires media-libs/mlt [+melt +kdenlive]

 

I've also update the kernel (gentoo-sources-3.15.6 (but either with the "Stable)"

 

Then now the system has Updated without any error

But i think that this post may be closed with success :)

 

If I'll have trouble withkdenlive, I'll open a new discussion.

 

Thank You Very Much (For All) :)

 

PS: I don't know if tag as solved for the answer of dantrell of sputnik......'cause both have found the solution.

Share this post


Link to post
Share on other sites
  • 0

Ok..... finally is All "consistent".

1) select ruby 19

2) euse -E melt kdenlive -p media-libs/melt

3) emerge kdenlive

4) Now it's all ok :P

 

Thank You again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×