Jump to content
funtoo forums
  • 0
adcdam

i get this python message when using portage after upgrade

Question

4 answers to this question

Recommended Posts

  • 0

Updated stable and current funtoo are running python2.7.12 and python3.4.5
The python-exec configuration was not updated and is still pointing to python3.3 which is no longer on your system.
Open a terminal, as root user:

eselect python edit

At the bottom of the text delete python3.3
Save and exit.

Type this command and hit Enter:

eselect python list

You should see:

funtoo rj # eselect python list
Available Python interpreters, in order of preference:
  [1]   python3.4 (fallback) 
  [2]   python2.7 (fallback)

Now update with this command:

funtoo rj # eselect python update
Switching to python3.4

Verify update:

funtoo rj # eselect python list
Available Python interpreters, in order of preference:
  [1]   python3.4
  [2]   python2.7 (fallback)

The error should be gone when you use portage.

Share this post


Link to post
Share on other sites
  • 0

Thanks Cardinal, you always help me, i did sudo eselect python edit but i got this:

!!! Error: EDITOR is not set
Call stack:
    * do_edit (python.eselect:181)
    * check_do (core.bash:24)
    * do_action (core.bash:105)
    * main (eselect:181)
exiting

so i read this

 

Default editor

Funtoo Linux also has a special meta-command called eselect, which can be used to set many default system settings. One of the things it is used for is to set the default editor used by things like crontab -e, etc that will automatically start an editor when run. Here is how to use eselect to change the default system editor:

# eselect editor list
Available targets for the EDITOR variable:
[1] /bin/nano
[2] /bin/ed
[3] /usr/bin/ex
[4] /usr/bin/vi
[ ] (free form)
# eselect editor set 4
Setting EDITOR to /usr/bin/vi ...
Run ". /etc/profile" to update the variable in your shell. After logging in again, or typing source /etc/profile in the current shell, the new system editor will be active.

Note that if you want to use vim instead of a vi through busybox you also need to run:

# eselect vi set vim

 

 

i did that as root i did sudo eselect editor set 4

and then source /etc/profile and then sudo eselect vi set vim
 

and then i got the same

!!! Error: EDITOR is not set
Call stack:
    * do_edit (python.eselect:181)
    * check_do (core.bash:24)
    * do_action (core.bash:105)
    * main (eselect:181)
exiting

i select vim instead of nano because i like more vim

i also tried with nano but i got the same error.

 

 

 

i also did this, as root i edited the file without eselect editor

sudo vim  /etc/python-exec/python-exec.conf 

i deleted python3.3 at the bottom of the file, followed the rest of your advice, that solved the python problem in Portage, but i want to have that eselect editor feature.

also if i try

eselect python edit but not as root it open the file with the selected editor but i can not save since im not root.
 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×