Jump to content
funtoo forums
  • 0
hick518

wifi not working - ath10k

Question

I've installed linux-firmware, which provided many of the firmware files needed for my wifi card, but I've still got some errors in /var/log/messages:

Dec  9 15:07:33 acer kernel: [   13.938036] ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/pre-cal-pci-0000:02:00.0.bin (-2)
Dec  9 15:07:33 acer kernel: [   13.938037] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/pre-cal-pci-0000:02:00.0.bin failed with error -2
Dec  9 15:07:33 acer kernel: [   13.938047] ath10k_pci 0000:02:00.0: firmware: failed to load ath10k/cal-pci-0000:02:00.0.bin (-2)
Dec  9 15:07:33 acer kernel: [   13.938048] ath10k_pci 0000:02:00.0: Direct firmware load for ath10k/cal-pci-0000:02:00.0.bin failed with error -2

equery l linux-firmware

 * Searching for linux-firmware ...
[IP-] [  ] sys-kernel/linux-firmware-99999999:0

I verified that wifi does work with a USB dongle, so I'm pretty sure I don't have a configuration issue with wicd or with my access point.

 

I ran the following two commands and neither produced any output, so it seems that nothing in portage provides the files that /var/log/messages is complaining it can't find.

equery belongs pre-cal-pci-0000:02:00.0.bin
equery belongs cal-pci-0000:02:00.0.bin

Any ideas what could be wrong?  Do I just have hardware that's not supported?  This is a brand-new laptop.

 

lspci -v

02:00.0 Network controller: Qualcomm Atheros Device 0042 (rev 31)
        Subsystem: Lite-On Communications Inc Device 08a6
        Flags: bus master, fast devsel, latency 0, IRQ 131
        Memory at b1000000 (64-bit, non-prefetchable) [size=2M]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable+ Count=1/8 Maskable+ 64bit-
        Capabilities: [70] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [148] Virtual Channel
        Capabilities: [168] Device Serial Number 00-00-00-00-00-00-00-00
        Capabilities: [178] Latency Tolerance Reporting
        Capabilities: [180] L1 PM Substates
        Kernel driver in use: ath10k_pci
        Kernel modules: ath10k_pci

By the way, I am using debian-sources-4.8.7.

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0
  • 0

Thanks Cardinal.  It looks like the guy in the first link is even using the same revision as me, so there is hope.

 

I should have clarified this earlier:  iwconfig shows the wifi card, and wicd sees my two access points.  But on one access point it fails to get an IP address, and on the other it fails on my security password (and I verified several times that the password is correct).  I had considered this to be a sort of half-working wifi card, and I thought the remaining firmware errors were causing the problem.  Maybe not, though.

Share this post


Link to post
Share on other sites
  • 0

My wifi is working now that I switched to a new access point with 802.11n.  It is running DD-WRT.  The other two access points I tried (which I could not connect to) were 802.11g.  I tried upgrading one of them to DD-WRT and that didn't improve anything.  So I think maybe the lack of wireless-N on my original access points was the problem.

 

My wifi card was able to see the 802.11g access points, but would fail to get an IP address or sometimes fail on authentication.  My guess is that the wifi card attempted to switch to 802.11n, which the access point couldn't handle.  I don't know if this would be a bug in wicd or in the ath10k firmware.  If anyone has suggestions of how to troubleshoot this, I will try to figure it out.

 

I will try to connect to other 802.11g access points as the opportunity arises, and will regularly update linux-firmware and wicd to see if I get any improvements.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×