Jump to content

Photo

Ugly Fonts Firefox

- - - - - ugly fonts firefox

Best Answer spectromas , 27 May 2015 - 04:06 PM

Right click on the ugly fonts and Inspect Element>Computed (on the right hand side). There should be an entry for 'font-family', I think the one in quotes " " should be the one used. Then if you click on Fonts you can see the font you are using, so for example Computed might tell you Arial (which is what the website wants to use) and Fonts will tell you Liberation Sans (which is the font your computer has set as a replacement/alias for Arial) and this is the one it is using to display the page.

 

You can use 'eselect fontconfig list' to see which rule you have enabled, perhaps you can just enable a few more fonts there. I personally don't really bother with that though and just enable the user.conf in eselect and set up rules for fonts in ~/.config/fontconfig/fonts.conf. The simplest solution for fonts.conf I've found is using the croscorefonts and the config on the arch wiki here https://wiki.archlin.../Croscore_Fonts, you could change this for your own choice of fonts, Arimo is very similar to liberation sans.

 

Alternatively, there is now an ebuild for infinality-fontconfig-ultimate in the gentoo/funtoo tree (media-fonts/infinality-ultimate-meta) so that would be the quickest and easiest way to get decent fonts, although perhaps not the lightest way.

 

One other thing to mention is that if you emerge media-fonts/liberation-fonts make sure you don't get the 2.* version, it is has bugs with bold fonts (terrible kerning and uneven spacing), I read somewhere, the red hat bug tracker I think, that the 2.* series was abandoned and the fixes were put in to 1.*. Interestingly enough 2.* is marked as stable in funtoo's tree and 1.* as current but my system installed 2.* automatically probably because the version number was higher.

Go to the full post »


2 replies to this topic

#1
Xerxes Lins

Xerxes Lins

    Newbie

  • Members
  • Pip
  • 9 posts

Hi, I am new on Funtoo.

Some text fonts are ugly in Firefox (some websites), but OK in Google Chrome.

(Without rendering?)

Please, best view in fullscreen:

http://imgur.com/43BAM2h

http://imgur.com/fCJfrIy


What can I do for try fix it?

Thank you



#2
spectromas

spectromas

    Advanced Member

  • Members
  • PipPipPip
  • 81 posts
✓  Best Answer

Right click on the ugly fonts and Inspect Element>Computed (on the right hand side). There should be an entry for 'font-family', I think the one in quotes " " should be the one used. Then if you click on Fonts you can see the font you are using, so for example Computed might tell you Arial (which is what the website wants to use) and Fonts will tell you Liberation Sans (which is the font your computer has set as a replacement/alias for Arial) and this is the one it is using to display the page.

 

You can use 'eselect fontconfig list' to see which rule you have enabled, perhaps you can just enable a few more fonts there. I personally don't really bother with that though and just enable the user.conf in eselect and set up rules for fonts in ~/.config/fontconfig/fonts.conf. The simplest solution for fonts.conf I've found is using the croscorefonts and the config on the arch wiki here https://wiki.archlin.../Croscore_Fonts, you could change this for your own choice of fonts, Arimo is very similar to liberation sans.

 

Alternatively, there is now an ebuild for infinality-fontconfig-ultimate in the gentoo/funtoo tree (media-fonts/infinality-ultimate-meta) so that would be the quickest and easiest way to get decent fonts, although perhaps not the lightest way.

 

One other thing to mention is that if you emerge media-fonts/liberation-fonts make sure you don't get the 2.* version, it is has bugs with bold fonts (terrible kerning and uneven spacing), I read somewhere, the red hat bug tracker I think, that the 2.* series was abandoned and the fixes were put in to 1.*. Interestingly enough 2.* is marked as stable in funtoo's tree and 1.* as current but my system installed 2.* automatically probably because the version number was higher.



#3
Xerxes Lins

Xerxes Lins

    Newbie

  • Members
  • Pip
  • 9 posts

Thanks!

I solved with your help !

I created the file "~/.config/fontconfig/fonts.conf" and pasted the following link content:

https://wiki.archlin.../Croscore_Fonts

And I ran the command:

$ sudo fontconfig eselect enable ~/.config/fontconfig/fonts.conf

After restarting Firefox, the fonts were OK.

:D


  • spectromas likes this



Reply to this topic



  



Also tagged with one or more of these keywords: ugly, fonts, firefox

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users