Jump to content

Photo

About compiling in ram.


Best Answer whiteghost , 26 October 2016 - 03:48 AM

tmpfs                       /tmp                     tmpfs noatime         0 0
tmpfs                       /var/tmp/portage  tmpfs  size=8G,uid=portage,gid=portage,mode=775,noatime 0 0
tmpfs                       /dev/shm              tmpfs  nodev,nosuid,noexec,noatime                  0 0

Go to the full post »


2 replies to this topic

#1
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 340 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

Hi to all

shm                     /dev/shm        tmpfs           exec,rw,mode=1777      0 0

I use this method and by default i've shm = 8 GiB (ram is 16 GiB).

I compile all in ram without troubles; only for debian kernel I had necessity of more ram (however i'm a gentoo-sources user)... solved increasing the size of /dev/shm from 8 to 16 GiB.

 

It is a good choice or there are better ways (for example about security or other things) ?

 

Thanks for answers.



#2
whiteghost

whiteghost

    Advanced Member

  • Members
  • PipPipPip
  • 34 posts
✓  Best Answer

tmpfs                       /tmp                     tmpfs noatime         0 0
tmpfs                       /var/tmp/portage  tmpfs  size=8G,uid=portage,gid=portage,mode=775,noatime 0 0
tmpfs                       /dev/shm              tmpfs  nodev,nosuid,noexec,noatime                  0 0


  • Sandro likes this

#3
Sandro

Sandro

    Advanced Member

  • Members
  • PipPipPip
  • 340 posts
  • LocationSaronno, Via IV Novembre, 23 21047 Italy

Ok ... i've comprised now !!!

sandro@ci74771ht ~ $ cat  /etc/fstab                                                                                                                                                                                                                                            
# /etc/fstab: static file system information.                                                                                                                                                                                                                                   
#                                                                                                                                                                                                                                                                               
# The root filesystem should have a pass number of either 0 or 1.                                                                                                                                                                                                               
# All other filesystems should have a pass number of 0 or greater than 1.                                                                                                                                                                                                       
#                                                                                                                                                                                                                                                                               
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.                                                                                                                                                                                                      
#                                                                                                                                                                                                                                                                               
# See the manpage fstab(5) for more information.                                                                                                                                                                                                                                
#                                                                                                                                                                                                                                                                               
# <fs>                  <mountpoint>    <type>          <opts>          <dump/pass>                                                                                                                                                                                             
                                                                                                                                                                                                                                                                               
/dev/sda5       /boot                   ext4    noauto,noatime,discard                          1 2                                                                                                                                                                             
/dev/sdb3       none                    swap    sw                                              0 0                                                                                                                                                                             
/dev/sda6       /                       ext4    noatime,discard                                 0 1                                                                                                                                                                             
/dev/sdb2       /home                   ext4    noatime                                         1 2                                                                                                                                                                             
/dev/sdb1       /mnt/Volume             ntfs-3g defaults                                        0 0                                                                                                                                                                             
#/dev/cdrom     /mnt/cdrom              auto    noauto,ro                                       0 0                                                                                                                                                                             
shm             /dev/shm                tmpfs   defaults                                        0 0                                                                                                                                                                             
tmpfs           /var/tmp/portage        tmpfs   uid=portage,gid=portage,mode=775,noatime        0 0 

My fstab:

sandro@ci74771ht ~ $ df -h 
File system     Dim. Usati Dispon. Uso% Montato su
none            7,9G  1,2M    7,9G   1% /run
udev             10M     0     10M   0% /dev
shm             7,9G  140K    7,9G   1% /dev/shm
/dev/sda6        41G   17G     23G  43% /
cgroup_root      10M     0     10M   0% /sys/fs/cgroup
/dev/sdb2       360G   28G    315G   9% /home
/dev/sdb1       550G  229G    322G  42% /mnt/Volume
tmpfs           7,9G     0    7,9G   0% /var/tmp/portage

 

Thanks Very mutch Dear Whiteghost  :)





Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users