Jump to content
Read the Funtoo Newsletter: Summer 2023 ×

genkernel Behavior and Kernel Makin'

Recommended Posts

I am using sys-kernel/genkernel-, which is exactly what I can get. Not sure what the old behavior was. I'm not sure of anything with computer admin.


It seems that if I run: genkernel --kernel-config=.config-0 --menuconfig all

and if I make some changes via the menu to the kernel configuration and save the configuration as: config-1

then, it seems to me, after I exit the configuration menu w/o more menu changes the .config is a copy of .config-0 and not .config-1.


I had thought that my menu changes would be part of the kernel about to be compiled, but it seems to not be the case. It seems the original configuration from the file specified by --kernel-config is used regardless.


Is that actually happening and if so, is that appropriate?


BTW, the funtoo documentation on compiling a kernel is really clear. So is the install documentation. Thank you.


Bonus question: know why my desktop settings get screwed up from compiling a new kernel to the same old kernel names under same old /boot? If that is the case. I have no idea. I don't understand how anyone can like making a linux distro and do it this well. The learning curve has spots without adequate documentation that are unique singleton show stoppers. (After two days trying to get clock="local" in /etc/conf.d/hwclock to work, I gave in and did clock="UTC"; can't remember the last time I booted the eeky Wyndoz.)


Anyway, I'm more careful now by running genkernel twice just to get the .config I want (and I could use make menuconfig but I now have an affinity with genkernel, especially since my attempt with raw make did not mount, and not investigating either, need to solve the intermitent exit Xorg/desktop dark screen lockup and get eth0 as a backup to wlan0 and then work on my computer lol).


Bonus, bonus: I think it is bizarre that the ethernet driver Realtek 8168 comes as package r8168 and the (newer?) driver Realtek 8169 is available in the kernel configuration. Maybe politics? Maybe the package driver is not good enough in quality to be in the kernel? I'm gonna give it a try. dmesg is happy with r8168, (which required that I get rid of 8169 for real, or at least according to /usr/src/linux/.config that had to be there) and that's as far I as am right now.


Best wishes to you in the new year!

Link to comment
Share on other sites

The problem with the official realktek driver is that they rely on (non-free) firmware sometime. Because of this there are packages like sys-kernel/linux-firmware (which you might need) and all the stuff in sys-firmware/* .


Regarding genkernel, I never had luck with that, it always just worked "kinda". Therefore I switchted to just compiling the whole thing manually, i.e.

cd /usr/src/linux
make menuconfig
make install
make modules_install
(... insert steps for building the ramdisk if you need it)

To be honest,  even after a few years of compiling kernels, I still have trouble configuring it on a new machine on my own and sometimes end up with a black X or similar. Therefore I always recommend to try out the debian-kernel package, which is kindly provided by funtoo and works just fine.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...