Jump to content
  • 0

set keyboard layout in xorg


adcdam
 Share

Question

I can use a Latin America layout in my window manager if i type in a terminal:

 

setxkbmap -layout latam -variant basic -model pc102

 

but how can i make this permanent at boot?

 

i tried creating this file /etc/X11/xorg.conf.d/10-keyboard.conf

and with this inside
 
Section "InputClass"
Identifier "keyboard-all"
Driver "eudev"
Option "Xkbmodel "pc102"
Option "XkbLayout" "latam"
Option "XkbVariant" "basic"
MatchIsKeyboard "on"
EndSection

 

but it didnt work.

Any help?

Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

Thanks i found the way reading the gentoo wiki https://wiki.gentoo.org/wiki/Evdev

i did this

 

cp /usr/share/X11/xorg.conf.d/10-evdev.conf /etc/X11/xorg.conf.d/

then i edited the file in /Etc

and in option Option "xkb_layout" i typed "latam"

so i have the latin America layout in xorg too.

 

i have lots of doubts between evdev udev eudev etc

Link to comment
Share on other sites

  • 0

 

 

 
 
Section "InputClass"
Identifier "keyboard-all"
Driver "eudev"
Option "Xkbmodel "pc102"
Option "XkbLayout" "latam"
Option "XkbVariant" "basic"
MatchIsKeyboard "on"
EndSection

 

Aren't you missing a quote?  Shouldn't Option "Xkbmodel "pc102" be Option "Xkbmodel" "pc102"?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...