Jump to content
Read the Funtoo Newsletter: Summer 2023 ×

[SOLVED] System update problem

Recommended Posts

funtoo /home/peter # emerge --ask --update --verbose --deep --newuse --with-bdeps=y @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] app-text/aha-0.5.1::kde-kit  386 KiB
[ebuild     U  ] sys-libs/e2fsprogs-libs-1.47.1::core-kit [1.47.0::core-kit] USE="split-usr -static-libs" 9.764 KiB
[ebuild     U  ] sys-libs/ncurses-6.5_p20240511:0/6::core-kit [6.4_p20240414:0/6::core-kit] USE="cxx gpm split-usr unicode -ada -debug -doc -minimal -profile -static-libs -test -tinfo -trace" 3.702 KiB
[ebuild     U  ] app-arch/xz-utils-5.4.6::core-kit [5.4.4::core-kit] USE="extra-filters nls split-usr -static-libs" 2.822 KiB
[ebuild     U  ] dev-db/sqlite-3.46.0:3::core-server-kit [3.45.3:3::core-server-kit] USE="icu readline secure-delete -debug -doc -static-libs -tcl -test -tools" 24.531 KiB
[ebuild  N     ] x11-apps/mesa-progs-8.5.0::core-gl-kit  USE="egl -gles2" 10.125 KiB
[ebuild     U  ] sys-fs/e2fsprogs-1.47.1::core-kit [1.47.0::core-kit] USE="nls split-usr threads -cron -fuse -lto -static-libs" 0 KiB
[ebuild     U  ] dev-python/setuptools-70.0.0::python-modules-kit [69.5.1::python-modules-kit] PYTHON_TARGETS="python2_7 python3_9 -pypy3 -python3_10 -python3_7 -python3_8" 2.213 KiB
[ebuild     U  ] net-libs/nghttp2-1.62.1:0/1.14::core-kit [1.62.0:0/1.14::core-kit] USE="cxx threads xml -debug -hpack-tools -jemalloc -libressl -static-libs -test -utils" 1.569 KiB
[ebuild     U  ] net-misc/curl-8.8.0::core-kit [8.7.1::core-kit] USE="ftp http2 imap ipv6 nss openssl pop3 progress-meter smtp ssl tftp -adns -alt-svc -brotli -gnutls -gopher -hsts -idn -kerberos -ldap -mbedtls -nghttp3 -quiche -rtmp -samba -ssh -sslv3 -static-libs -telnet -test -threads -zstd" CURL_SSL="openssl -gnutls -mbedtls -nss" 4.056 KiB
[ebuild     U  ] dev-python/trove-classifiers-2024.5.22::python-modules-kit [2024.5.17::python-modules-kit] PYTHON_TARGETS="python3_9 -python3_10 -python3_7 -python3_8" 16 KiB
[ebuild  N     ] app-misc/wayland-utils-1.2.0::core-gl-kit  15 KiB
[ebuild     U  ] dev-util/opencl-headers-2024.05.08::core-gl-kit [2020.12.18::core-gl-kit] 76 KiB
[ebuild  N     ] dev-util/vulkan-tools-1.3.236::core-gl-kit  USE="X -cube -wayland" 860 KiB
[ebuild     U  ] dev-python/typing-extensions-4.12.0::python-modules-kit [4.11.0::python-modules-kit] PYTHON_TARGETS="python3_9 -python3_10 -python3_7 -python3_8" 83 KiB
[ebuild  N     ] dev-util/opencl-icd-loader-2024.05.08::core-gl-kit  USE="-test" 92 KiB
[ebuild  N     ] dev-util/clinfo-  65 KiB
[ebuild     U  ] dev-python/requests-2.32.2::python-modules-kit [2.31.0::python-modules-kit] USE="ssl -socks5" PYTHON_TARGETS="python3_9 -pypy3 -python2_7 -python3_10 -python3_7 -python3_8" 128 KiB
[ebuild     U  ] dev-ruby/racc-1.8.0::ruby-kit [1.7.3::ruby-kit] USE="-doc -test" RUBY_TARGETS="ruby31 -ruby27 -ruby30 -ruby32" 447 KiB
[ebuild     U  ] dev-ruby/rdoc-6.7.0::ruby-kit [] USE="-doc -test" RUBY_TARGETS="ruby31 -ruby27 -ruby30 -ruby32" 750 KiB
[ebuild     U  ] gnome-base/librsvg-2.54.5:2::gnome-kit [2.48.8:2::gnome-kit] USE="introspection memsaver vala* -gtk-doc% (-tools%)" 23.058 KiB
[ebuild     U  ] media-video/pipewire-1.1.82::gnome-kit [1.1.81::gnome-kit] USE="X bluetooth gstreamer ssl v4l zeroconf -doc -echo-cancel -examples -extra -jack-client -jack-sdk -lv2 -pipewire-alsa -systemd -test" 2.346 KiB
[blocks B      ] dev-libs/ocl-icd ("dev-libs/ocl-icd" is blocking dev-util/opencl-icd-loader-2024.05.08)

Total: 22 packages (16 upgrades, 6 new), Size of downloads: 87.091 KiB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/ocl-icd-2.2.14:0/0::core-gl-kit, installed) pulled in by
    dev-libs/ocl-icd required by (x11-drivers/nvidia-drivers-535.86.05:0/535.86::core-gl-kit, installed) USE="X cuda egl (glvnd) opencl tools uvm wayland -acpi -static-libs"

  (dev-util/opencl-icd-loader-2024.05.08:0/0::core-gl-kit, ebuild scheduled for merge) pulled in by
    dev-util/opencl-icd-loader required by (dev-util/clinfo-, ebuild scheduled for merge) USE=""

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):


Kind regards,


Edited by sabaton
Link to comment
Share on other sites

Are you a kde user?

Or what is the output of

equery d clinfo


For me, this is a dependency conflict between nvidia-drivers and kinfocenter.


Disabling opencl use flag for nvidia-drivers would likely work, but maybe, like me, you don't really want to do that.

Otherwise, for the time being, need to remove kinfocenter (or whatever package wants clinfo) as it is a static dependency. That could be non-trivial if it is pulled in as part of a meta package.

Link to comment
Share on other sites

Posted (edited)

I installed Funtoo_Plasma as a guest system in VirtualBox.

funtoo /home/peter # equery d clinfo
 * These packages depend on clinfo:
kde-plasma/kinfocenter-5.27.9 (dev-util/clinfo)

I don't need NVIDIA drivers, I have "vmware" for VirtualBox.

What is the easiest solution to fix the problem?


Kind regards,


Edited by sabaton
Link to comment
Share on other sites

  • sabaton changed the title to [SOLVED] System update problem

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...