Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

My clock is an hour fast



   ~ % ls -l /etc/localtime

lrwxrwxrwx 1 root root 37 May  3 11:36 /etc/localtime -> /usr/share/zoneinfo/America/Vancouver

My computer clock currently says 11:51 AM. According to every other clock, it's more like 10:51. Daylight Savings started a few months ago already, so it's not that.


I first noticed the issue this morning.

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 0

i dont know, i use ntpd...  


cat /etc/conf.d/hwclock




mkultra@spaceball-1 ~ $ sudo /etc/init.d/hwclock status
* status: started


that makes the system read cmos time at start, and write cmos time at halt....  the kernel has some RTC stuff to do it also....  dig through the issue and start documenting solutions plz, im busy trying to figure out entropy stuff for ssl security.


"In-kernel method[edit]

On a sufficiently modern kernel (3.9 or newer), Linux can be configured to handle setting the system time automatically:

Device Drivers  --->
  [*] Real Time Clock  --->
    [*]   Set system time from RTC on startup and resume
    [*]   Set the RTC time based on NTP synchronization
The hwclock init script should not be ran when using the kernel's real time clock. Opting for this method will speed up the system's boot and shutdown processes slightly." -https://wiki.gentoo.org/wiki/Ntp


i did document sufficiently ntpd, the kernel entry is not mine though.


did that work for you?  if not you're probably going to have to change your clocks adjustment thing /usr/share/zoneinfo/America/Detroit


/etc/localtime -> /usr/share/zoneinfo/EST5EDT


uhhh for you its PST8PDT i think....

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...