Jump to content
Read the Funtoo Newsletter: Summer 2023 ×
  • 0

SOLVED - Unable to use Swedish keymap under Xfce



I have just installed Funtoo on my Fujitsu Esprimo E and during post installation have been trying to  use the swedish keymap, under XFCE,  without success.  I suspected it was due to my limited experience, but after googling a longer while I got the impression that many have had similar problems.

It works well in the console though -  "keymap=sv/latin1"  in/etc/conf.d/keymaps..

My /etc/console.gen says:

en_US.UTF-8 UTF-8
sv_SE.UTF-8 UTF-8
pt_BR.UTF-8 UTF-8
zh_CN.UTF-8 UTF-8


eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   C.utf8
  [3]   POSIX
  [4]   en_US.utf8
  [5]   pt_BR.utf8
  [6]   sv_SE.utf8 *
  [7]   zh_CN.utf8
  [ ]   (free form)

Settings > Keyboard show Swedish as first choice,  "Use system default" is ON.

The apparently best answer I found was on https://forums.funtoo.org/topic/4879-polish-locales-it-might-be-helpful/#comment-17030 .

I did not dare tampering with make.conf, as advised on that thread, so that may be something to consider. Otherwise I think my settings correspond to what it is avised there. 

I tried login out of Desktop and then login out again from console and login in and starting Xfce, again but no effect..  Same for rebooting. Hmmmmm!!!!! ....  I did NOT try shutting down ????

But now I will post this, as I don't know how to save a post.  Will try shutting down immediately after posting and if it works will report immediately thereafter.



Edited by fredmyra
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0
setxkbmap -option grp:switch,grp:alt_shift_toggle

After much searching the confortable solution I found was in https://docs.slackware.com/howtos:window_managers:keyboard_layout_in_xfce :


Note: Also you can set your keyboard layouts manually, by:

setxkbmap -option grp:switch,grp:alt_shift_toggle

I enclose a summary of tips I found through my searching, hoping that it may be useful


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...