Jump to content
  • 0

Noob audio help, no sound on speakers with ALSA or Pulse


robbie
 Share

Question

Hi, I just set up Funtoo with the GNOME tarball. I've been able to get almost everything working, but I can't get any output on my laptop's speakers when headphones aren't plugged in. (It works as expected when headphones are plugged in, however.) I don't really know where to start; I'm a somewhat experienced Linux user but usually audio "just works." Here's my alsa-info.sh output if it helps in assisting me: http://alsa-project.org/db/?f=733b9dd5e484869c31ad78008960dfb2e80610b3

Edited by robbie
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

The default configuration is when the headphones are unplugged it disables the headphone volume.

In your case it appears the headphone volume controls the internal laptop speaker volume.

A potential workaround is to reconfigure the headphone volume so it isn't disabled when the headphones are unplugged.

nano /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

Change

[Element Headphone]
switch = off
volume = off

to

[Element Headphone]
switch = off
volume = merge

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...