Jump to content
  • 0

media-libs/gst-plugins-base-1.14.4-r1::media-kit ebuild fails


Go to solution Solved by cardinal,

Question

Greetings everyone,

I'm trying to build the plasma-meta packages, but I'm getting stuck at this ebuild:

[ebuild  N    ] media-libs/gst-plugins-base-1.14.4-r1  USE="X alsa egl introspection nls ogg opengl orc pango theora vorbis wayland -abi_riscv_lp64 -abi_riscv_lp64d -gbm -gles2 -ivorbis" 

The last several lines of the build are here:

libtool: link: x86_64-pc-linux-gnu-gcc -o /var/tmp/portage/media-libs/gst-plugins-base-1.14.4-r1/work/gst-plugins-base-1.14.4-abi_x86_64.amd64/gst-libs/gst/audio/tmp-introspect89oda8w9/.libs/GstAudio-1.0 -march=skylake -O2 -pipe /var/tmp/portage/media-libs/gst-plugins-base-1.14.4-r1/work/gst-plugins-base-1.14.4-abi_x86_64.amd64/gst-libs/gst/audio/tmp-introspect89oda8w9/GstAudio-1.0.o -Wl,--export-dynamic -pthread -Wl,-O1 -Wl,--sort-common -Wl,--as-needed -Wl,--export-dynamic  -L. -L/usr/lib64 -L../../../gst-libs/gst/tag/ ./.libs/libgstaudio-1.0.so -lgio-2.0 -lgmodule-2.0 -lgstbase-1.0 -lgstreamer-1.0 -lgobject-2.0 -lglib-2.0 -pthread -Wl,-rpath -Wl,/usr/lib64
/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.0/../../../../x86_64-pc-linux-gnu/bin/ld: error while loading shared libraries: libbfd-2.32.0.gentoo-sys-devel-binutils-st.so: cannot open shared object file: No such file or directory
collect2: error: ld returned 127 exit status
linking of temporary binary failed: Command '['../../../libtool', '--mode=link', '--tag=CC', 'x86_64-pc-linux-gnu-gcc', '-o', '/var/tmp/portage/media-libs/gst-plugins-base-1.14.4-r1/work/gst-plugins-base-1.14.4-abi_x86_64.amd64/gst-libs/gst/audio/tmp-introspect89oda8w9/GstAudio-1.0', '-export-dynamic', '-march=skylake', '-O2', '-pipe', '/var/tmp/portage/media-libs/gst-plugins-base-1.14.4-r1/work/gst-plugins-base-1.14.4-abi_x86_64.amd64/gst-libs/gst/audio/tmp-introspect89oda8w9/GstAudio-1.0.o', '-L.', '-L/usr/lib64', '-rpath', '/usr/lib64', '-L/usr/lib64', '-rpath', '/usr/lib64', '-L../../../gst-libs/gst/tag/', 'libgstaudio-1.0.la', '-lgio-2.0', '-Wl,--export-dynamic', '-lgmodule-2.0', '-pthread', '-lglib-2.0', '-lgstbase-1.0', '-lgstreamer-1.0', '-lgobject-2.0', '-lglib-2.0', '-Wl,-O1', '-Wl,--sort-common', '-Wl,--as-needed']' returned non-zero exit status 1.
make[5]: *** [Makefile:1733: GstAudio-1.0.gir] Error 1
make[5]: Leaving directory '/var/tmp/portage/media-libs/gst-plugins-base-1.14.4-r1/work/gst-plugins-base-1.14.4-abi_x86_64.amd64/gst-libs/gst/audio'
make[4]: *** [Makefile:918: all] Error 2
make[4]: Leaving directory '/var/tmp/portage/media-libs/gst-plugins-base-1.14.4-r1/work/gst-plugins-base-1.14.4-abi_x86_64.amd64/gst-libs/gst/audio'
make[3]: *** [Makefile:948: audio] Error 2
make[3]: Leaving directory '/var/tmp/portage/media-libs/gst-plugins-base-1.14.4-r1/work/gst-plugins-base-1.14.4-abi_x86_64.amd64/gst-libs/gst'
make[2]: *** [Makefile:624: all-recursive] Error 1
make[2]: Leaving directory '/var/tmp/portage/media-libs/gst-plugins-base-1.14.4-r1/work/gst-plugins-base-1.14.4-abi_x86_64.amd64/gst-libs'
make[1]: *** [Makefile:748: all-recursive] Error 1
make[1]: Leaving directory '/var/tmp/portage/media-libs/gst-plugins-base-1.14.4-r1/work/gst-plugins-base-1.14.4-abi_x86_64.amd64'
make: *** [Makefile:679: all] Error 2

The file that it's complaining about does exist in my system under /usr/lib64/binutils/x86_64-pc-linux-gnu/2.32/libbfd-2.32.0.gentoo-sys-devel-binutils-st.so.

Can anyone give me pointers on how to convince this ebuild to complete?

gst-plugins-base emerge info.txt

Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 1
  • Solution
Posted (edited)

I was able to build

media-libs/gst-plugins-base-1.14.4-r1

Your system has 2 versions of binutils .

While binutils is slotted which allows multiple versions installed at the same time, it's dependency binutils-libs is not slotted.

The installed binutils version must match binutils-libs version.

You have the old version of binutils-libs but your system is using the new version of binutils.

sys-devel/binutils:       2.32-r1::core-kit, 2.36.1-r1::core-kit

Verify install or upgrade to binutils-libs-2.36.1-r1

emerge -1av =sys-libs/binutils-libs-2.36.1-r1

The end result is to only have binutils-2.36-r1 and binutils-libs-2.36-r1 on your system.

Then try using --depclean first, or if necessary -Ca to remove the old version binutils-2.32-r1 

 

My system:

rj@funtoo ~ $ ego query v binutils
 sys-devel/binutils |     slot|                 repo
-----------------------+---------+---------------------
                2.32-r1|   0/2.32| core-kit/1.4-release
-----------------------+---------+---------------------
            * 2.36.1-r1| 0/2.36.1| core-kit/1.4-release
rj@funtoo ~ $ ego query v binutils-libs
 sys-libs/binutils-libs|     slot|                 repo
-----------------------+---------+---------------------
                2.32-r1|   0/2.32| core-kit/1.4-release
-----------------------+---------+---------------------
            * 2.36.1-r1| 0/2.36.1| core-kit/1.4-release

rj@funtoo ~ $ emerge --info | grep binutils
sys-devel/binutils:       2.36.1-r1::core-kit

 

 

 

Edited by cardinal
More details.
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...