Jump to content
  • 0

Qt5 apps don't use the GTK style in non-GNOME desktops


jorgicio
 Share

Question

I tried setting the XDG_CURRENT_DESKTOP, and XDG_SESSION_DESKTOP to GNOME, and the QT_STYLE_OVERRIDE to gtk, and it doesn't work. In fact, it uses the Windows one. Also, it doesn't use the GTK file dialog, but the QStyle one.

I'm using MATE, and QT 5.4.1.

If qtwidgets wasn't compiled with gtk style, hoy can I do?

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Nevermind, I got what happened:

 

qtwidgets has gtkstyle disabled by default. A workaround, is unpacking, editing the configure script to force the gtkstyle enabled, compiling "manually", all with ebuild. Then, restart the session. Now it's working, but it still uses the QFileDialog, but GTK+-ish.

 

I hope this would be fixed in future releases, because editing that file every compiling time, is boring.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...