Jump to content
  • 0
hick518

"Filter failed" for Brother DCP-7065dn

Question

For a while now I haven't been able to print to my Brother DCP-7065dn printer.  It used to work.  I've got net-print/brother-dcp-7065dn-drivers installed.  I've also tried re-installing it. 

One thing I notice is that all binaries in /usr/local/Brother/Printer/DCP7065DN are 32-bit.  Should these work on my Funtoo 1.4 system?

I've set cups logging to "debug", but haven't gotten anything useful out of the logs. 

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Unfortunately I can not assist you, but I have a very similar problem. I try to get my Brother HL1210W (networked) to work under Funtoo 1.4 (freshly installed), but it does nothing. I have installed the Brother drivers from their website (lpr+cupswrapper), everything is set properly in the CUPS administration interface, and there a no error messages when I send out a printjob. I also have reinstalled CUPS, but to no avail. My user is member of the group lp. 

(The printer itself is working fine under openSUSE 10.3, openSUSE 12.3 (from within VirtualBox under 10.3), Windows, Android).

Any ideas?

Mm.

Share this post


Link to post
Share on other sites
  • 0

You can get more logging out of cups by making this change to cupsd.conf:

replace

LogLevel warn

with

LogLevel debug

There's also a debug2, which is probably overkill.

Share this post


Link to post
Share on other sites
  • 0

Thank you for your answer. I did what you suggested. Trying to print some Text with Leafpad gets the following output.

I don't exactly understand everything, but it does not look really bad. However, the printer did absolutely nothing. (It is turned on :)

I [18/Apr/2020:16:24:56 +0200] Listening to [v1.::1]:631 (IPv6)
I [18/Apr/2020:16:24:56 +0200] Listening to 127.0.0.1:631 (IPv4)
I [18/Apr/2020:16:24:56 +0200] Listening to /run/cups/cups.sock (Domain)
I [18/Apr/2020:16:24:56 +0200] Remote access is disabled.
D [18/Apr/2020:16:24:56 +0200] Added auto ServerAlias funtoo
I [18/Apr/2020:16:24:56 +0200] Loaded configuration file "/etc/cups/cupsd.conf"
D [18/Apr/2020:16:24:56 +0200] Using keychain "/etc/cups/ssl" for server name "funtoo".
D [18/Apr/2020:16:24:56 +0200] Repairing access permissions of "/var/cache/cups"
I [18/Apr/2020:16:24:56 +0200] Using default TempDir of /var/spool/cups/tmp...
I [18/Apr/2020:16:24:56 +0200] Configured for up to 100 clients.
I [18/Apr/2020:16:24:56 +0200] Allowing up to 100 client connections per host.
I [18/Apr/2020:16:24:56 +0200] Using policy "default" as the default.
I [18/Apr/2020:16:24:56 +0200] Full reload is required.
I [18/Apr/2020:16:24:56 +0200] Loaded MIME database from "/usr/share/cups/mime" and "/etc/cups": 78 types, 113 filters...
D [18/Apr/2020:16:24:56 +0200] Loading printer Brother_HL-1210WE...
D [18/Apr/2020:16:24:56 +0200] load_ppd: Loading /var/cache/cups/Brother_HL-1210WE.data...
D [18/Apr/2020:16:24:57 +0200] cupsdRegisterPrinter(p=0x558fea59b570(Brother_HL-1210WE))
I [18/Apr/2020:16:24:57 +0200] Loading job cache file "/var/cache/cups/job.cache"...
D [18/Apr/2020:16:24:57 +0200] [Job 5] Loading from cache...
I [18/Apr/2020:16:24:57 +0200] [Job 5] Data files have gone away.
E [18/Apr/2020:16:24:57 +0200] Bad File number 1 on line 15 of /var/cache/cups/job.cache.
D [18/Apr/2020:16:24:57 +0200] [Job 5] Loading from cache...
D [18/Apr/2020:16:24:57 +0200] [Job 7] Loading from cache...
D [18/Apr/2020:16:24:57 +0200] [Job 8] Loading from cache...
D [18/Apr/2020:16:24:57 +0200] [Job 9] Loading from cache...
D [18/Apr/2020:16:24:57 +0200] [Job 9] Loading attributes...
D [18/Apr/2020:16:24:57 +0200] [Job 9] Unloading...
D [18/Apr/2020:16:24:57 +0200] cupsdAddSubscription(mask=0, dest=(nil)(), job=(nil)(0), uri="(null)")
I [18/Apr/2020:16:24:57 +0200] Full reload complete.
D [18/Apr/2020:16:24:57 +0200] cupsdCleanFiles(path="/var/spool/cups/tmp", pattern="(null)")
I [18/Apr/2020:16:24:57 +0200] Cleaning out old files in "/var/spool/cups/tmp".
D [18/Apr/2020:16:24:57 +0200] cupsdCleanFiles(path="/var/cache/cups", pattern="*.ipp")
I [18/Apr/2020:16:24:57 +0200] Cleaning out old files in "/var/cache/cups".
D [18/Apr/2020:16:24:57 +0200] service_checkin: pid=6248
D [18/Apr/2020:16:24:57 +0200] Creating KeepAlive/PID file "/run/cups/cupsd.pid".
D [18/Apr/2020:16:24:57 +0200] Calling FindDeviceById(cups-Brother_HL-1210WE)
D [18/Apr/2020:16:24:57 +0200] FindDeviceById failed: org.freedesktop.ColorManager.NotFound:device id \'cups-Brother_HL-1210WE\' does not exist
D [18/Apr/2020:16:24:57 +0200] Using profile ID "Brother_HL-1210WE-Gray..".
D [18/Apr/2020:16:24:57 +0200] Calling CreateProfile(Brother_HL-1210WE-Gray..,temp)
D [18/Apr/2020:16:24:57 +0200] Created profile "/org/freedesktop/ColorManager/profiles/Brother_HL_1210WE_Gray__".
I [18/Apr/2020:16:24:57 +0200] Registering ICC color profiles for "Brother_HL-1210WE".
D [18/Apr/2020:16:24:57 +0200] Calling CreateDevice(cups-Brother_HL-1210WE,temp)
D [18/Apr/2020:16:24:57 +0200] Created device "/org/freedesktop/ColorManager/devices/cups_Brother_HL_1210WE".
D [18/Apr/2020:16:24:57 +0200] Calling /org/freedesktop/ColorManager/devices/cups_Brother_HL_1210WE:AddProfile(/org/freedesktop/ColorManager/profiles/Brother_HL_1210WE_Gray__) [soft]
I [18/Apr/2020:16:24:57 +0200] Listening to [v1.::1]:631 on fd 6...
I [18/Apr/2020:16:24:57 +0200] Listening to 127.0.0.1:631 on fd 7...
I [18/Apr/2020:16:24:57 +0200] Listening to /run/cups/cups.sock on fd 8...
I [18/Apr/2020:16:24:57 +0200] Resuming new connection processing...
D [18/Apr/2020:16:24:57 +0200] cupsdSetBusyState: newbusy="Not busy", busy="Active clients"
D [18/Apr/2020:16:24:57 +0200] cupsdAddCert: Adding certificate for PID 0
D [18/Apr/2020:16:24:57 +0200] Discarding unused server-started event...
D [18/Apr/2020:16:24:57 +0200] cupsdSetBusyState: newbusy="Not busy", busy="Not busy"
I [18/Apr/2020:16:24:58 +0200] Expiring subscriptions...
D [18/Apr/2020:16:24:58 +0200] Report: clients=0
D [18/Apr/2020:16:24:58 +0200] Report: jobs=5
D [18/Apr/2020:16:24:58 +0200] Report: jobs-active=0
D [18/Apr/2020:16:24:58 +0200] Report: printers=1
D [18/Apr/2020:16:24:58 +0200] Report: stringpool-string-count=538
D [18/Apr/2020:16:24:58 +0200] Report: stringpool-alloc-bytes=7784
D [18/Apr/2020:16:24:58 +0200] Report: stringpool-total-bytes=10112

 

Does this make sense to anyone? Is this good or not?

Mm.

Share this post


Link to post
Share on other sites
  • 0

In my case I was getting "filter failed" in error.log, so your case seems to be a little different than mine.  Anyway, I never solved my issue and instead installed a 32-bit Devuan virtual machine, running on my Funtoo host, and made that my print server.  The Brother drivers worked fine there.

Here are some of my notes from setting up the VM:

https://forums.funtoo.org/topic/4469-starting-a-qemu-virtual-machine-at-boot/

Share this post


Link to post
Share on other sites
  • 0

That sounds quite interesting to me. Unfortunately I have no idea how to do this. Qemu is installed and running fine, but there are two thing I would ask now:

1) Do I have to completely install another OS (32-bit) in Qemu or are there any pre-built images available for the purpose of an printserver? [update] I finally found the pre-built Devuan images. [/update]

2) How does CUPS in funtoo send its printjobs to the VM? It will have its own IP address I suppose, but I do not understand how it works in detail.

Mm.

Edited by moldmaker

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...