Jump to content
  • 0
kindofblue

kernel not starting on an lvm root file system

Question

Hello everybody,

I just installed Funtoo release 1.4 on an AMD K10 cpu; the kernel is debian-sources-lts version 4.19.67_p2-r1. I used LVM for all the file systems, including the root file system (I used the instructions in the following guide).

I used the following kernel parameters in /etc/boot.conf (again from the guide mentioned above): dolvm real_root=/dev/funtoo/ROOT rootfstype=ext4 resume=swap:/dev/mapper/funtoo-SWAP. When booting I see the following messages:

Quote

vgscan and vgchange not found: skipping LVM volume group activation

Block device /dev/funtoo/ROOT is not a valid root device

I have another box running Funtoo release 1.3 with version 4.19.37_p6 of the Debian kernel. I have the same setup on this one as the new one (using LVM for the root file system) and it works fine. There's differences in relation to LVM in the initramfs files of the two kernels. Here's what I see for version 4.19.37_p6:

Quote

etc/lvm
etc/lvm/lvm.conf
bin
bin/lvm

etc/modules/lvm

And only this for version 4.19.67_p2-r1

Quote

etc/modules/lvm

Could that explain the issue?

Thanks in advance.

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Your boot parameters look fine. Mine look a little different but I don't think it's the issue.

params += dolvm root=UUID=33179502-4a4e-456d-8ca8-eb0b73320235 rootfstype=ext4 resume=swap:UUID=78238a3f-6cd6-4cf5-b1a4-14fb7ad3856f quiet

Do you have lvm flag enabled for your kernel? That's what fixed the issue for me.

$ equery u debian-sources-lts
[ Legend : U - final flag setting for installation]
[        : I - package is installed with flag     ]
[ Colors : set, unset                             ]
 * Found these USE flags for sys-kernel/debian-sources-lts-4.19.67_p2-r3:
 U I
 + + binary        : <unknown>
 - - btrfs         : <unknown>
 + + custom-cflags : Build with user-specified CFLAGS (unsupported)
 - - ec2           : <unknown>
 + + luks          : <unknown>
 + + lvm           : <unknown>
 - - sign-modules  : <unknown>
 - - zfs           : <unknown>

 

Share this post


Link to post
Share on other sites
  • 0

Sorry I just saw your answer. I rebuilt the kernel with Device Mapper Support built in (instead of a module) and it's now working. I was not aware of the lvm use flag. I added it and I'm now emerging debian-sources-lts again. I'll let you know how it goes. Thanks a lot.

 

Share this post


Link to post
Share on other sites
  • 0

The lvm flag didn't work for me. I still see the same messages at boot time as those I posted in my original message. At least I have a working kernel with the manual build of the kernel I described.

Thanks again.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...