Jump to content
  • 0
Sign in to follow this  
kea0463

[SOLVED]Need help with update problem

Question

[sOLVED]Hi, when I went to update my funtoo system, I ran into a emerge problem,

thet says cannot install both packages on system, was asking how do i fix this:

sudo emerge -auDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] sys-boot/efivar-0.15
[ebuild  N     ] sys-boot/efibootmgr-0.11.0
[ebuild     U #] app-admin/eselect-opengl-1.3.1 [1.2.7]
[ebuild     U #] x11-proto/glproto-1.4.17-r1 [1.4.17]
[blocks b      ] <x11-proto/glproto-1.4.17-r1 ("<x11-proto/glproto-1.4.17-r1" is blocking app-admin/eselect-opengl-1.3.1)
[ebuild  N     ] media-libs/mesa-10.3.5  USE="classic dri3 egl gallium gbm llvm nptl udev -bindist -debug -gles1 -gles2 -opencl -openmax -openvg -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -vdpau -wayland -xa -xvmc" VIDEO_CARDS="(-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware"
[ebuild     U  ] x11-base/xorg-server-1.16.2-r2 [1.16.1-r1]
[blocks b      ] <x11-base/xorg-server-1.16.2-r1 ("<x11-base/xorg-server-1.16.2-r1" is blocking app-admin/eselect-opengl-1.3.1)
[ebuild   R    ] dev-qt/qtgui-4.8.6-r1  USE="egl*"
[ebuild   R    ] sys-boot/grub-2.02_beta2-r3  GRUB_PLATFORMS="efi-64* pc*"
[ebuild   R    ] x11-libs/libva-1.4.1  USE="egl*"
[ebuild     U  ] sys-boot/boot-update-1.7.2 [1.7.1]
[blocks B      ] =media-libs/mesa-10.3.5 ("=media-libs/mesa-10.3.5" is blocking app-admin/eselect-opengl-1.3.1)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (media-libs/mesa-10.3.5::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/mesa-10.2:* required by (www-client/firefox-34.0.5-r1::gentoo, installed)
    >=media-libs/mesa-9.1.6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[abi_x86_64(-)]) required by (virtual/opengl-7.0-r1::gentoo, installed)
    media-libs/mesa[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (media-libs/mesa[egl,abi_x86_64(-)]) required by (dev-qt/qtgui-4.8.6-r1::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-10.3.4-r1[nptl=] (>=media-libs/mesa-10.3.4-r1[nptl]) required by (x11-base/xorg-server-1.16.2-r2::gentoo, ebuild scheduled for merge)
    >=media-libs/mesa-9.1.6[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[egl,abi_x86_64(-)]) required by (x11-libs/cairo-1.12.18::gentoo, installed)
    media-libs/mesa[egl] required by (net-libs/webkit-gtk-2.4.4::gentoo, installed)
    >=media-libs/mesa-9.1.6[egl,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] (>=media-libs/mesa-9.1.6[egl,abi_x86_64(-)]) required by (x11-libs/libva-1.4.1::gentoo, ebuild scheduled for merge)

  (app-admin/eselect-opengl-1.3.1::gentoo, ebuild scheduled for merge) pulled in by
    >=app-admin/eselect-opengl-1.3.0 required by (x11-base/xorg-server-1.16.2-r2::gentoo, ebuild scheduled for merge)
    >=app-admin/eselect-opengl-1.3.0 required by (x11-proto/glproto-1.4.17-r1::gentoo, ebuild scheduled for merge)
    >=app-admin/eselect-opengl-1.2.7 required by (media-libs/mesa-10.3.5::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

firefox requires mesa 10 webkit-gtk requires mesa 9.1.6....  id remove firefox & put google-chrome on the system....  that totally doesn't address the issue.....

 

the issue is mesa 10.3.5 is B(locking) your emerge...  which is pulled in by eselect opengl 1.3.1  id try re-syncing & re merging

Share this post


Link to post
Share on other sites
  • 0

ok i got it knocked down to this, i tried adding +mod, use

flag then it messed up more, so i deleted that this is what i

get now:

 

 

sudo emerge -auDN @world

These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds built with USE flags to satisfy "media-libs/sdl-mixer[mod,vorbis]".
!!! One of the following packages is required to complete your request:
- media-libs/sdl-mixer-1.2.12-r4::gentoo (Change USE: +mod, this change violates use flag constraints defined by media-libs/sdl-mixer-1.2.12-r4: 'midi? ( any-of ( timidity fluidsynth ) ) timidity? ( midi ) fluidsynth? ( midi ) mp3? ( any-of ( smpeg mad ) ) smpeg? ( mp3 ) mad? ( mp3 ) mod? ( any-of ( mikmod modplug ) ) mikmod? ( mod ) modplug? ( mod )')
(dependency required by "games-board/pokerth-1.1.1[-dedicated]" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...